Joplin 1.0.174 does not open properly

I’ve downloaded the latest version of Joplin portable, placed the new EXE file over the old one and now when I open Joplin it shows in the system tray and there is an icon in the task-bar but no GUI and no notes.
Then, I tried opening with the old version and got a message that notes require the latest version so there you go… my notes are inaccessible after the update.

What I did next, I downloaded the latest install package (not portable) installed it using -run as admin- option and still the same issue is present. There is Joplin icon in the system tray, there is Joplin icon in the taskbar but there is no GUI and notes cannot be accessed.
I’ve restarted my machine a few times but to no avail.

I’m on Win10 pro 64bit

Isn’t it because the window is off-screen? https://www.techjunkie.com/find-recover-off-screen-window-windows-10/

coincidentally?, the same thing happened to me. tried downgrading to 173 and the window was still missing. Hmm… Looking through the log files revealed nothing out of the ordinary. Oh, I Know what it is… the window went off screen somehow… And, a simple “cascade windows” from the right-click on the taskbar brought the window back to the screen. Win7, fwiw…

came here to see if it was known and well, here’s another data point.

Yes, correct. As I am (still) using Joplin daily I have to do this -cascade windows- thing a few times a day as Joplin window is kind of -lost-.
However, I find the guys here pretty tough on admitting any issues so I won’t argue anymore.

I’ve been using Joplin for more than a year now and I haven’t seen this behavior. It might be specific to Windows. It could be Electron. Without being able to reproduce it, it’s kind of hard to say that it is a bug.

I know there are a few issues specific to macOS which I hope will be fixed when we upgrade Electron.

Also, the information provided is a bit sparse. Are people who experience this problem using multiple monitors? Does this happen all the time? When does it happen?
Currently I know the following: Joplin is off-screen on Windows.

FWIW, It doesn’t seem to be a commonly occuring bug. I use Joplin on 2 different PCs, both of them with 2-3 monitors each. One even gets docked/undocked often, so the number of displays changes and windows jump about like crazy. Never had any issue like this.

It happens every single time when I click the icon to start Joplin. It starts and the icon appears in the task-bar but there is no way to get the UI to show unless I use the “cascade windows” option from the task-bar.

This issue does nor occur in version 1.0.178 - I’d say, it has been resolved.