Joplin gets stuck while starting

I’ve got a problem with Joplin since this morning, last night it still worked.

OS: Win 10
Joplin Version 1.0.220

It seems to start, but shows never a Window. However, I can see the Joplin App in the taskbar that it is started. But wenn I click on it, I can’t see a window for it. Windows key + Tab shows me a window but when I select it, it won’t show. Also tried to send it to another desktop.

Did try:

  • Restart computer
  • Reinstall (including Version 1.0.227)
  • Close everything and restart again

What can I do for this to resolve?

Thank you!

Does that work?

No, that didn’t work unfornately. However, what I’ve noticed: I can see Joplin sometimes when I click on the Joplin tile in the taskbar. It lasts only for a split of a second and is something like a flicker, but it’s definitvely Joplin because I can see an image in it that I’ve put into Joplin.

Hmm, then it seems it’s crashing on startup. Is there any info in the log?

And how about in the Windows event log?

I was unable to open the development tools / console tab. I did create the flags.txt file with the debug statement in it. There was no change.
Joplins log file seems to work but there seems not to be anything unusual. The entries there seem to be the same like the days before the erroneous behavior.
As for the Windows event log, could you tell me more specific what I should look for, please? I’m not really familiar with the Windows event log.

I’ve googled for your the first link, I’m sure you can google the second one about Windows event log.

Would you mind uploading the logs?

I will, don’t worry, but I’m very busy at the moment. Thanks for asking again and having patience though!

I was just able to open it again after I had the idea to open it in the office where I’ve got a second screen. The window was most probably just stuck in the imaginary other screen (extension) and when I was home where I only have the laptops screen, it Joplins window wouldn’t show on my (primary) screen. So it was actually stuck in the extended screen. This also explains why there probably is no error message for this phenomenon.
I’ve moved the window into my primary screen. It now works again, but this seems to be a bug. It is however, solved for me now.