Home / GitHub Page

Joplin, I love you... but this is driving me nuts (Dropbox)

So, today I updated Joplin to the latest version. As expected, it works flawlessly :slightly_smiling_face:

However, since the update I get this message Every! Five! Minutes! That Dropbox deleted some sync file (probably based on my syncing preferences). Even when I’m not using Jopling at all. I understand that it may be necessary to create a more robust syncing feature, but this is driving me insane… could you please, pretty please reconsider deleting this file every five minutes (once a day or even every few hours would be just fine)?

2 Likes

I’ve got the same issue as you, but the file is deleted (and I think created) when Joplin syncs from my mobile. Do you have another desktop with a syncing interval of 5 minutes? I bet that’s the cause.

btw You can turn off dropbox notifications, so unless you want them for some other purpose then maybe consider turning them off.

@laurent what is the purpose of this file and is it possible to perhaps change the system a bit to prevent it from getting deleted so often?
image

1 Like

Thanks CalebJohn, currently I’m only using it on one desktop. I have it on my Android as well, but that one hasn’t updated yet and gives the dreaded error - I know that will be corrected when the Google store updates the version :smiley:

I thought about disabling the DB notifications but unfortunately I need them for other projects I use with it. I can absolutely live with a few notifications a day, but it’s the 5 minute interval that makes it so invasive.

Of course another alternative is changing the sync frequency of Joplin, but… I kinda like the 5 minute updates in case I do suddenly decide to write/update a note and know it’ll be available on my phone almost instantly.

Oh forgot to mention: mine mentions “You deleted sync_desktop_etc” instead of mobile, as yours does.

Screenshot 2020-09-04 18.10.45

1 Like

I use Nextccloud sync in Joplin and every time I changed a file, I got a notiifcation from the Nextcloud client that a file was updated. The same happened at every sync.

Thus I excluded the Joplin directory from the Nextcloud sync client. I’m using Nextcloud sync in Joplin so there’s no reason that the Nextcloud sync client syncs that directory as well.

Unless you use filesystem sync in combination with the Dropbox sync client you can do the same.

2 Likes

Oh that’s a good idea. I have never used selective sync, so I didn’t even think of that. I’ll try excluding the folder but still hoping for a solution that doesn’t delete the file every five minutes.

Thanks guys, for the replies and suggestions :slight_smile:

1 Like

What happens is that before sync starts, a lock file is created to tell other clients that sync is in progress, and once it’s finished the lock file is deleted.

It’s now part of the way sync works so this behaviour can’t be disabled unfortunately. I’m planning to write a post to explain why these changes are necessary as it’s true they can cause small annoyances like this.

Best if you can is indeed to exclude the joplin sync dir, or just the lock dir as that’s where files are created and deleted.

3 Likes

Right, I am going to exclude the Joplin folder from syncing, so it’s all good now :slight_smile: It just never occurred to me as an option but really there is no reason to have the folder on my local hard drive anyway.

Thanks again!

1 Like

Hold on, doesn’t this mean that if you exclude the Joplin folder from the sync, you don’t get synchronisation across devices? Or is my brain not understanding what’s going on here?

You still have sync across devices :slight_smile:
Joplin uses the dropbox api to handle sync, the suggestion was to disable the sync of Joplin files from Dropbox to a Local folder.
This means that the Joplin files will still be accessible to Joplin clients but won’t be synced by the desktop dropbox client (which was never necessary or desired).

Right @CalebJohn I think I am a little slow on the uptake today. Now to find where I can configure this selective sync in Fedora. Now officially my problem only! Thanks for replying and explaining the use of the API.

I’m dense here. What exactly should I do? Joplin seems to use on my MS Windows computer a folder C:\Users\<myUserName>\Dropbox\Appar\Joplin, that’s within my Dropbox folder hierarcy. I assume, that on my Mac Joplin uses the same folder. So what should I do to have synchonisation across my devices but getting rid off of those annoying notifications?

Unless you’re using filesystem sync target at that folder, then joplin wasn’t using it for sync anyways (because it performs sync directly with the cloud). You can go into the settings for the Dropbox application and direct it to not download the Joplin folder.
This won’t interfere with Joplin because it interacts directly with the cloud and doesn’t depend on the local sync client.

I hope that clears things up!

1 Like

I think, I have done as instructed by Joplin years ago, when I took it into use. Anyway now I deselected the Jopling folder mentioned above and tested with a new note. I did get synchonised to my phone and an edit I made there got back. Now if the notifications stay away, I’ve reached my goal. Thanks!

“Local sync client” etc. are Hebrew for laymen, so I hope that there is a “Joplin for dummies” documentation that explains terms.

1 Like

For the record, on Linux you can simply run this command to fix this issue (update with relevant path):
attr -s com.dropbox.ignored -V 1 /your/path/to/Dropbox/Apps/Joplin/locks/

as mentioned above by @laurent you might want to ignore the sync dir as well:
attr -s com.dropbox.ignored -V 1 /your/path/to/Dropbox/Apps/Joplin/.sync/

not sure if you need to ignore the .lock and temp dir though.

More info, and how to do this on Mac and Win as well:

However, as mentioned above as wel, a better option is to ignore syncing Apps/Joplin by removing that folder from the desktop app.

2 Likes

Can confirm that just excluding the Apps\Joplin.sync folder eliminates all the 15 minute interval messages, while still allowing all other notifications to come through (I like the confirmation that my note edits are indeed synced for some crazy reason). I have no issues with it now :smiley:

2 Likes