Homepage    |    GitHub    |    API    |    FAQ

Joplin, I love you... but this is driving me nuts (Dropbox)

Thank you so much. Finally, it's fixed! For those who are still guessing where the setting is, here is a screenshot.

3 Likes

I had the same issue (see earlier in this thread). I think the default for Dropbox is to synchronise all. What I was trying to convey, is that the set up instructions for Joplin should more clearly say that you need to change that sync all behaviour of Dropbox.

1 Like

I followed the suggestion to remove the Joplin folder from Dropbox sync earlier in the day. After several hours I tried to rename one of my notes and it wouldn't work. I fumbled around a bit, then discovered that none of my edits today have been saved. In trying to troubleshoot, I went to open Tools-Options and it froze up the entire app. I'm on Ubuntu -- is the above suggestion only applicable to Windows and/or Mac?

When you said you followed the suggestion, can you describe EXACTLY what you did with Dropbox?

Yeah, sorry. I unchecked the box next to Joplin in the Selective Sync dialog. Pretty much like the screenshot by @voteforjoplin except that I'm on Ubuntu so it looks a bit different. It's worth noting that Dropbox deletes the folder on the disk when you do this. I thought it would be OK since @tessus said that "You don't have to sync the Joplin folder at all. Because sync is taken care of by Joplin itself."

Strange. How did you set up sync? You didn't set up Dropbox as the data folder? Sorry I'm not a Linux user so I wouldn't really know...

In Tools > Options > Synchronisation was your Synchronisation Target set up using the "Dropbox" connector? This links Joplin directly with Dropbox. You do not actually need the Dropbox client on your computer to allow the Joplin sync to work. I believe that this is what @tessus means by, "Because sync is taken care of by Joplin itself."

However, if your synchronisation target was set to "File system" and you then used a folder in your "Dropbox" folder as the target (or any folder being monitored by the Dropbox client) the loss of that folder will, understandably, cause everything to fail.

2 Likes

Excellent clarification. I do, in fact, have Dropbox as the Synchronization target. I set it to 12 hours to minimize the interruption, but would like to set it much shorter.

image

Thanks for clarifying and yes, this is what I meant. It was a reply with a post in mind that was a few pages up. Maybe I should have repeated it.

What interruption? If you mean the Dropbox notifications, they should stop now you have told the Dropbox client not to download an unnecessary copy of your Joplin data.

Set it to something shorter. Mine is set at 5 mins (which I think is the default)

Well, I'm not sure what I did wrong the first time, but I removed the Joplin folder from Selective Sync again (I put it back shortly after removing it the first time) and everything is working fine now. Thanks for the helpful feedback everyone.

1 Like

Well so much for that. I just lost few days' worth of journal notes because although it appeared to be working, it was apparently failing silently. When I opened a different note and then back to my journal note, nothing I added since January 6 was there.

Something must be off with your setup. I have used Joplin for a year now on various devices and not lost a single note. Do you see those lost notes in Dropbox? You can restore files within 30 days.

I would suggest you create a backup of your notes (export feature), wipe your user folder, uninstall Joplin, wipe the sync folder in Dropbox. Then build it back gradually and see if that works.

Also, do not manually copy files from one device to another, make sure you allow Dropbox to do the syncing.

2 Likes

It seems this no longer works. It now completely breaks the sync (see also Error: POST files/list_folder: Error (409) - #10 by PhiLho).

@ Kvothe

Can you specify what breaks? Are you saying that you still get notifications?

There are two things here.

  1. Take a look at the image posted by gaterman at 2021-01-05. You select Dropbox as a target. This means that Joplin will use built-in Dropbox code to do the synchronisation, which means it does not use the Dropbox application you have installed.

  2. Take a look at the image posted by voteforjoplin at 2020-11-20. If you have the Dropbox application on your computer, go and apply selective sync so that the whole Joplin folder is not synchronised.

1 Like

I have the same setting as in the gaterman image. By breaking things I meant that synchronization fails completely when I ignored some joplin files from the dropbox sync same as PhiLho did on the thread I linked. Perhaps I misunderstood something though. Hee in this thread people seem to use a different form of selective sync to get a dropbox sync without continuous notification. Perhaps I will look at it again at some later time.

I changed to one drive and it seems to work. And there I won't mind it if it is pointlessly synchronizing stuff every second since I don't receive notifications from it. Hope it keeps working. I saw some other threads that said that one drive was problematic with Joplin so I am hoping for the best.

When I was testing Joplin Cloud, I was switching back and forth to Dropbox and I can confirm it's still working just fine with or without selective sync.

However Joplin Cloud is so convenient and fast that I see no reason to go back to self hosting. It's great to have options though, whatever works best!