Homepage    |    GitHub    |    API    |    FAQ

Too frequent "timeCheck" files in Dropbox

Hi, I am using Joplin 1.0.245 on Linux and I have noticed that now roughly every 10 minutes a "timeCheckxxxxx.txt" file gets deleted from Dropbox. This leads to constant notifications from Dropbox that "You have deleted 4 files" which is very distracting.

I don't think this was the case before. Has something changed? Is there a setting where I can disable this or force it out of the Dropbox folder at least?
Thanks

I believe that if you are syncing Joplin directly with Dropbox you can use the Dropbox client settings to tell it not to sync another copy back down into the main Dropbox folder on your PC. Then the notifications should stop.

1 Like

@dpoulton do you mean to basically stop syncing the Joplin folder?

Depends what you mean by "stop syncing the Joplin folder" :slight_smile:

I am referring to the situation where you sync Joplin to Dropbox using the Dropbox connector in Joplin settings AND also have the Dropbox client installed on your system. Joplin sends data directly to your online Dropbox from its data store located at /home/<username>/.config/joplin-desktop. However if the Dropbox client is set to sync everything it will then download and duplicate that all back into the folder managed by your Dropbox client (/home/<username>/Dropbox(?)) and the Dropbox client will send you a notification to tell you what it has done. So if this is your situation you can go into the Dropbox client settings and do a selective sync (ie untick the folder Joplin uses (/Apps/Joplin). It will not duplicate your Joplin data back onto your system and so doesn't need to notify you about anything.

5 Likes

Gotcha, thanks. That's what I meant. It makes sense :slight_smile:

Sorry for labouring that point but when replying to forum posts I find that it's better not to assume that the poster means what I think they mean!!

1 Like

This really ought to be stickied

Solved. Thank you for the concise answer!

I also was getting multiple dropbox notifications of a file being deleted on Linux PopOS.
I am using Pop!_OS 20.04 LTS / GNOME 3.36.3

Thanks, I can finally suppress those deleted notifications!

I found another topic in which @laurent explains what the timeCheck files are specifically for with the same suggestion to disable syncing the Joplin directory in the Dropbox client settings