Home / GitHub Page

[iOS] Sync Stopped Working (after evernote import)

#1

Everything was working for months, but after importing a few hundred notes from evernote into the desktop app, it appears that the iOS app stopped syncing (using Dropbox). I removed/reinstalled the app and restarted the initial sync, but it stopped at the same number of notes. Now it just hangs with the message:
x Cancel synchronisation

My assumption is that I had an attachment larger than the current size limit, but I have no idea how to see what resources might be causing the hang. Any tips?

#2

Can you check on Dropbox in Joplin/.resources what is the largest resource?

#3

Excellent. Thank you. I have two resources over the (10MB?) limit. I’ve now found them in .config/joplin-desktop, but I don’t know the best way to deal with the situation.

So far:

  • Moved both files out of the desktop resources directory
  • Tried to sync desktop (Message: Completed)
  • Reloaded dropbox .resources (files still there)
  • Waited 5 minutes (no good reason)
  • Repeated synch and reload (no change)
  • Deleted the two resources from dropbox
  • Repeated desktop sync (Completed)
  • Double checked dropbox
  • Restarted iOS sync (Still hanging)
    edit:
  • Removed iOS app
  • Reinstalled and restarted sync
    edit2:
    Sync completed!

Thank you again for the help and as always for all the work you put into this!

#4

What is the size limit for synchronisation?

I can’t get synchronising to work at all on my iPad. I’ve tried it on Dropbox, OneDrive and now WebDAV on my local network. The desktop syncs 3500 notes (imported from Evernote) but the iPad always fails after between 1000 and 2000 items. The latest on WebDAV is that it says it has created 1078 local items but I don’t see them and it’s stuck at X Cancel syncronisation. Killing and restarting the app makes little difference - sometimes it says it’s created a few more items. The largest resource is under 7Mb.

#5

I have about 5500 items and they sync fine on desktop, Android and iOS so 3500 notes shouldn’t be a problem. I really don’t know why it would get stuck in your case. Just to be sure, did you try letting it run for several hours, like overnight?

#6

Yes, I’ve left it overnight and nothing happens. It always starts off well with the item count showing about 2 items being created every second and then it just stops, showing no item count and the X Cancel sync message.

Although there are 3500 notes the sync log on desktop shows that there are over 10,000 items.

#7

Both Android and IPad perk up now and again and report downloading more notes on WebDAV. They didn’t do that on Dropbox or OneDrive. I’ll leave them to see what happens.