iOS and Dropbox synchronisation not working

Bug report is there:

Like it says in the title, notes I create on my iPhone no longer show up on other Joplin platforms (on my laptop or PC). Notes I create on Joplin on Windows sync with the Mac installation, and vice versa.

I use Dropbox. Usually it works, but today it abruptly stopped pushing notes from mobile to the other platforms. I reinstalled, but the issue still persists. Here is some of my sync log (with errors only):

I am not very tech-savvy, so I can't make sense of any of this. Also, in case it helps, I've attached the sync status:

It seems like there are two notes missing, or I am two revisions behind. Please let me know what I can do to fix this. Thanks.


Exact same issue here, with the same error messages in the log (except for a different UUID). It had been working flawlessly until some point in the last 24-48 hours.

I thought it might be a Dropbox issue, but Dropbox appears to be working fine.

1 Like

Looks like an issue has been raised on Github here: Error in setting Dropbox sync in iOS app · Issue #6375 · laurent22/joplin · GitHub

I want to confirm that I have the same issue on my iOS devices and Windows mashine.

1 Like

Hi, folks,

After working perfectly for my first week two, my iPhone has stopping syncing to DropBox. The PC is working just fine. Here’s my error log.

Thanks for any help!


1 Like

me too, notes created on iphone are not syncing via dropbox and the notes created on mac or pc do not get to the iphone..started sometime in the last 24 hours or so

1 Like

The same here, boring :frowning:

I thought it was just me. Started about a day ago and signed up to the forum to dig through to see what might be wrong. I may have resolved the issue, but we'll see.


  • My most recent note versions are on macOS. They seemed to be syncing up from macOS, but on iOS it would complete sync without showing any changes. Changes on iOS also did not reflect on macOS.
  • Toggling sync method on iOS or macOS did not appear to do anything.
  • Disabling encryption on either did not appear to do anything.
  • Reenabling encryption on either did not appear to do anything.
  • Updating Joplin on macOS did not appear to do anything.
  • Changing macOS to use filesystem and pointing to the Dropbox folder instead of using the Dropbox sync option didn't make any noticeable difference. Seemed a bit quicker to sync up to Dropbox though.
  • Deleting and reinstalling the iOS app did nothing.
  • Forcing the iOS app to redownload from sync target did not appear to pull down the new files.
  • Forcing macOS to reupload to sync target did not appear to do anything.

Possible Solution

Really only viable if you don't have anything to lose on iOS.

  • Delete app on iOS.
  • Keep or sync to filesystem pointing to Dropbox folder on macOS.
  • Disable encryption.
  • Synchronise.
  • Enable encryption.
  • Synchronise.
  • Install app on iOS.
  • Set sync to Dropbox.
  • Synchronise.
  • Enable encryption.
  • Synchronise.

This was not great, and I'm not sure which of these steps actually made a difference, but it appears to have nudged sync into working for now. Unsure if it will fail again.

I uninstalled and reinstalled on iphone, the authorization and initial sync to dropbox worked. Created a new note on iphone and that note did not sync to the installs on my mac and windows computers. I didn't try disabling, then enabling, encryption. Not sure what that was supposed to do. Please keep us posted if you have a permanent fix or if you experience problem again. Thank you :slight_smile:

actually i have never used encryption, so would not have done that step...

Nope. Was mistaken. After all that, still doesn’t update on iOS. Or at least it works after doing all that then stops.

Log shows Network Request Failed when it syncs and at one point has “remote does not exist, local is new and has never been synced” which seems suspicious.

thank you for the update
I have signed up for joplin cloud, will use that until this is solved
you get a free 2 week trial so can do no-cost for two weeks, I will pay for at least a month to make at least a small contribution to this great software

the switch to joplin cloud was easy and pretty quick even for 13,000 notes

1 Like

It would appear the same bug has befallen me - which I only report because I'm running old versions of Joplin, which worked fine until a day or perhaps 2 days ago. PC version 2.4.12, it would seem the IOS version is 12.4.2.

I run a static version of win 10 (no updates for some time) and an old version of IOS.

This suggests to me the issue is with dropbox protocols or the like.

1 Like

Me too. Win10 to iPhone and iPad. Dropbox sync has worked flawlessly for 2 years (don’t do encryption) so I saw no need to change.

Now Joplin Cloud has been running a while without issues I think it is time to switch to the Pro plan.

Even with iOS 12.4.2 is happens? Could you double check the version please? If that's so it probably means it's a change on Dropbox that's causing this.

iOS 15.3.1
Joplin 2.7.1
Database v41
FTS enabled 1

ios joplin app version = "Joplin 12.4.2"

version of IOS itself is = 14.8.1

I don't have a github account, so I will post the log I have here - only way I know to do that from ios is to screenshot it - is there some way to capture the log as text?

I'll note that I turn off automatic updates and do not run encryption.

I am also getting "Network request failed" error with e2e and dropbox target.
ios: 15.3.1
joplin: 12.7.1