iOS app not syncing to dropbox

I've been using Joplin with the iOS and Mac applications for a couple of years. On 5/2 or 5/3, the iOS app stopped syncing with Dropbox. The logs cycle through the below messages and the sync status never updates. (This screenshot shows that I've closed and reopened the app several times, but even with leaving the app open for 30 minutes to sync, it never completes.) There are no errors in my log other than some errors related to not allowing access to location, which went away when I updated this through the iOS settings.

app version: 12.7.2
Sync target: Dropbox
e2ee enabled: yes
Database: v41
FTS enabled: 1

Things I've tried:

  • increasing the number of max concurrent connections (based on a similar post) from 6 to 12. I've also tried 1 and 20.
  • waiting
  • updating app to 12.7.2
  • updating synchronization target to none then changing back to Dropbox
  • updating attachment behavior to manual, then changing back to always
  • cancelling the synchronization and restarting (it attempts to cancel but does not cancel successfully)

Is there anything else I should try? I've considered deleting the app and re-downloading it, but since my notes on this device have not synced yet I would like to avoid that step if possible.

I was able to fix this by disabling screen lock (default is 5 minutes), updating the Mac app to 2.7.15, and disabling a VPN on mobile.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.