How to set Markup editor by default

guys when i create new note then by default this html code editor show up so i have every time to toggle.

so any idea how i can set markup editor by default so that when i create new note editor is in markup mode not in html mode.


Hi, welcome

Have a look at this plugin

1 Like

This should be persisting by default.
If you go to your profile directory (Help > Open Profile directory - if on Mac this might be in a different menu but I'm not sure) then open up your settings.json there should be a line in there called "editor.codeView": that sets to true when the markdown editor is open and false when the rich text editor is open.
If you switch editors and open the file you should see that changing and that influences the behaviour when it next opens.
If this isn't updating can you provide the log files and details of your system as requested in the support template that you removed?

hmmmm i opened the settings file and changed "editor.codeView": true, false to true . and restarted Joplin then it was in markdown mode but after switching to html mode backforth then it stop showing markdown mode on new note creation mode.

i think they should add this option to setting that upon new note creation what would be editor mode by markdown or html


great this plugin fix this problem . cool

I'm confused as to how this solved the issue, what exactly did you mean by the "html code editor"?
Edit - looking at the plugin it does have the ability to call toggleEditors but it sounds like something is wrong somewhere and this is just masking it if Joplin isn't writing (or reading) the current editor type in the settings file.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.