How to debug image on desktop but not iOS

Windows Desktop Version: 1.4.19
iOS Version: 10.3.1, Database v34

I recently migrated from Evernote to Joplin on Desktop. Then enabled sync via Dropbox (no E2E encryption - never enabled.) I then synced my notes ~4000 notes and many more resources to my phone. Many notes show on the phone correctly including notes with attached PDF file, png files, etc.

I've discovered a few notes where the attached images do not show on iOS but the same notes on desktop do show.

I have tried with attachment download behavior set to Auto and Manual. As I have a lot of attachments I'd prefer to not download all attachments to my phone.

I have tried quitting and restarting the app on iOS to see if the attachment would be re-downloaded.

I've tried updating the note title on desktop and syncing. The title change does appear on iOS but the image reference continues to not work. Visually the "broken" attachment appears looks like an empty rectangle (possibly a placeholder for a missing thumbnail.)

I have seen the "missing" attachment with both .png and .jpg files.

I tried editing the note on iOS adding some text to the body and syncing to desktop. The text shows with the image on Desktop. Image still does not show on iOS. So issue is clearly something to do with resolving the resource the note title/body appears to be working just fine.

I have read this thread: Images not showing on desktop and android but not found anything that helps with my situation there.

I have also read this thread: I see an icon rather than an image in my note on Android but not found anything that helps with my situation.

I've looked in the log and not found any errors related to this. Would be good to be able to clear the log as there is a bunch of noise from when I tried switching to S3 backend a while back. Note this issue pre-dates that attempt. I'm back on Dropbox sync which appears fine.

Updated to Joplin 10.4.1 on iOS and it does not appear to have solved the issue.

Here is a sample note:

![Evernote Snapshot 20180925 172927.jpg](:/c2333f7f9209ebf9df1e54ad86736800)


The file ~/.config/joplin-desktop/resources/c2333f7f9209ebf9df1e54ad86736800.jpg exists and is valid on Desktop. Not sure how to check if this file exists on iOS. Same file exists in Dropbox but without the .jpg extension. I wonder if that may be the root cause?

I made a copy of this image to my Desktop and added it back to the same note (so now it is in the note twice.) I was offered to down sample the image, to which I declined. After syncing, the newly added image does show on both desktop and iOS but the old image still only shows on Desktop and not on iOS. Following is what was added to the note:


The file on desktop ends in .jpg but on Dropbox it still has no extension, so apparently the lack of an extension is not why the original file is broken.