Images on iOS missing only when imported from enex

Hey! So this is my first attempt at Joplin and I'm running into a problem with images not synchronizing on iOS, but only when they were originally imported from an enex.

tl;dr: Latest versions, images in notes imported from enex files are not visible on iOS, images imported from jex or attached to new notes work fine.


  • Windows: 1.2.6 (prod, win32)
  • macOS: Whatever is current 1.2.6 (prod, darwin)
  • Terminal: 1.3.3 (prod)
  • iOS: 10.2.1.

Synchronization target: OneDrive.
iOS client configured to download attachments Always.

Steps to reproduce:

  1. Export content from Evernote into enex.
  2. Import into Joplin from desktop or terminal client.
  3. Synchronize desktop/terminal.
  4. Synchronize iOS client
  5. View the note from each platform.

On desktop platforms images show up fine, on mobile, they're missing and just have a small square instead.

The note itself just looks like this:
![Photo on Oct 21, 2020 at 19_30_01.jpg](:/eed201113f20d5d2e724bff8a8b1a812)

I've tried making a copy of the note on the desktop, this too will not be visible on iOS.

Just to fiddle around a bit, I created a new note and pasted this (using IDs from images that did and did not work elsewhere), Yup.jpg works on mobile, Nope.jpg and AlsoNope.jpg does not -- This probably isn't useful, but it proves the problem isn't with the imported notes themselves, but maybe their attachment somehow?


If I create a new note on desktop and attach that same image by saving the file and re-uploading, then it is visible on iOS. Additionally, if on the desktop I export out to jex and then re-import? Image is visible on iOS there too.

I've tried force-killing the iOS app. I did see a previous article discussing the option to download images not always working, so I fiddled with it it a bit, but again, images work except when imported from an enex.

I tested importing from an enex and a jex on both the Windows client and Terminal, the results were the same -- It always works from Windows, and macOS, but it never works from iOS.

At least in theory I guess I could import all the enex files, export everything to jex, wipe, and do a fine re-import, but it really doesn't seem like this should be necessary.

Any logs that would be useful? I'm still getting familiar with the platform and haven't dug into the logs yet. I did check the sync status though, and no attachments reported errors. Interestingly(?) there were move Downloaded and decrypted attachments on iOS than on Windows, despite both having a "Always" setting, but I'm not really sure if these humbers should be identical across devices or not.