Having trouble resetting password on Docker Joplin

Joplin version is 2.7.4-beta, running on Synology Docker. It's reverse-proxy'd, so I can access it from outside of my home network.

I've been having issues with my install:

  • I've been trying to sync Docker with a new app (Android)
  • The app is configured the same as the two other apps that are currently working (Mint Linux, Windows 10). I have the synchonization target to Joplin Server (Beta), and my URL, email, and password the same.
  • Android is giving me a 403 (invalid username or password) when I thought I was inputting the correct password. As it stands, I've tested my Windows desktop (removing the password to "break" my sync config, then re-entering what I thought was the correct password), but it seems the password in my vault is incorrect.

I'm not sure how I would reset/retrieve my password. I found this post explaining how to go into my database.sqlite file; I couldn't find encryption.passwordCache in a text editor, or a browser for the database file. Reading a second time, this is because this is the encryption password, whoops.

I also followed the directions here about enabling email for my Docker instance (in order to get an email to input a new password, but I'm getting an error EmailService: Could not run maintenance: Error: Could not initialize transporter. Service will be disabled: getaddrinfo ENOTFOUND smtp-relay.gmail.com which I imagine is related to trying to use my G Suite account to relay the email.

I'm not exactly sure what I should be doing, or how I could set up email properly to reset my password. I currently have one Desktop App (Linux) with the proper setup and password (it's still working); I'm not sure if I could recover my password from that, somehow. My other option seems to be just resetting the whole thing, and importing a previous backup of my Joplin notes.

Sorry, fixed this myself.

I messed up putting in an env variable in Docker. MAILER_HOST had some leading spaces when I was copying from a tutorial. I also think that enabling "Less Secure App Access" might've let me use Gmail's SMTP.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.