Reset settings ins content in Joplin Server with Docker

Hi all,

currently I am running Joplin Server (Version: Joplin Server 2.11.1) on a RPi.
Installation was straightforward using this tutorial: "Guide for Joplin-Server on Raspberry Pi" in this forum with docker.

Now I want just start over with a fresh version of Joplin (including resetting the PW and all data).
I already tried just deleting the docker container - all the settings and content is still there.

What is the smartest way to reset joplin and all user data but keeping apache server & everything else?

Thank you very much!

@huababua welcome to the forum.

Shut down the server with docker-compose down

In your docker-compose.yml file you will see a volumes: entry showing where the PostgreSQL data is stored on your machine

    - /path/to/joplin-data:/var/lib/postgresql/data

If you delete the actual folder named to the left of the colon (in the above example /path/to/joplin-data) it will remove ALL user data and account info. Then when you bring the server back up again it will start up as new and accounts will have to be created etc.

1 Like

Hi dpoulton,

thank you very much for your quick response and sorry for my late answer.

Resetting Joplin worked perfectly fine but unfortunately after changing the admin password and a restart I cant log in anymore as it says "invalid username/password".

I already searched the forum for some similar problems and wanted to double check if this is the issue:
Obviously the latest build (what I am using) version doesn't contain an image for RPi and I should use the oldest master build?


I can only guess that it is a typo when you set the new password that is causing the problem. Try a reset again.

Joplin does not provide a Joplin Server image for ARM however others do. This post gives links to Docker Hub for images provided by florider89 and etechonomy and they are normally updated to the latest version very quickly after the latest official version is released.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.