Home / GitHub Page

Dont open in Catalina 10.15.4

I get this message on Macbook Pro “Joplin.app” cannot be opened because Apple cannot check for malicious software. I also have tried to make in security “open anyway”

Open Finder. Go to Applications. Right click on Joplin and Open. Does this solve the issue?

No, Im sorry but it doesnt open the application
Thanks any way

Same issue here.

How did you install Joplin? homebrew OR dmg file.
Which version of Joplin you’ve installed?

I installed with dmg file the last version 1.0.197 Also I have tried brew but the “command not found”

Ohh great. I am just about to update to 10.15.4 macOS version and for the issue of command not found , you have to first install brew and place it’s path. Follow instructions on https://brew.sh/

Ok I have installed brew and after installed Joplin but the same message: “Joplin.app” cannot be opened because Apple cannot check for malicious software.

Ohh then i guess it’s a system preference problem, because i just updated to latest os :sleepy:
IT WORKS THOUGH!!
macOS : 10.15.4
Joplin: 1.0.197
As you can see in the image below.

What you should do is go to System Preferences -> Security and Privacy and unlock the setting by clicking on left bottom lock icon and in the bottom Allow apps downloaded from: should be set to App Store and unidentified developers

This is wath I did including “open anyway” but its the same… Im very sorry.

Can you show me a screenshot/screen-record of what it shows? or the best way you can try downloading the .dmg file and install it again.

the message says also that the application does not come from an identified developer


The message is in spanish “Joplin.app” cannot be opened because Apple cannot check for malicious software.

Open System Preferences and then Security & Privacy and allowed from there?

I have tried to install four times in different ways but the same results. IM sorry

Yes I made it also but without success

You tried all of these steps?

Yes, I have tried all those steps… :hot_face:

@josefcarel The last resolve will be that you can disable Gatekeeper from Terminal.

  • Finder > Go > Utilities
  • Launch Terminal
  • Enter: sudo spctl --master-disable
  • Run your install
  • If you would like to reenable when done: sudo spctl --master-enable