Can't Open Joplin After Latest Update

I've been using Joplin for about 6 months and have loved it. I'm running macOS Catalina (10.15.1) and have updated Joplin once before after upgrading to Catalina. The previous update was Joplin version 1.0.173 to 1.0.174. I got a warning after installing it that it couldn't be opened because Apple couldn't check it for malicious software but I went into System prefs > Security and Privacy and it had an "Open Anyway" option. That worked and all was well.

Until I got a notice that Joplin 1.0.175 was available. So I downloaded it (version 1.0.175) and updated like before, allowing it to open just like before after getting the warning.

It opens but NOTHING is visible. It's like there is no UI. I checked to make sure it's not in another desktop or hidden somehow. I can see the menu at the top of the window for Joplin but if I select a new note or anything else nothing happens. If I select export a small window does pop up from the bottom left of my monitor to allow me to browse to the folder I want to export it to.

I use Joplin for my own development documentation and I just checked the folder I thought it was using to save my files but it hasn't been updated with any of my updates for months! If nothing else I would love to know where Joplin might have saved those files and if they are recoverable? There is information in there I would hate to lose.

Can I downgrade somehow to version 1.0.174 on macOS and see if that works?

I have tried to turn on debugging but since I can't see anything I can't see the debug info :slight_smile:

I see no errors or warnings in the error log but please let me know if I should look for something else.

Last, I have tried restarting and that did not help. I am running macOS in dark mode.

Not sure what to try. Any help greatly appreciated!

I found the 1.0.174 version to download from github and after installing it found the issue. The window with the notice to update to the newer version again opened from the bottom left of my screen. When I closed it the notice faded into the corner and when my mouse moved over that area I found it changed. The screen had been shrunken down to 1px somehow and I found I could grab and drag it over to be able to see Joplin again! I can’t replicate that since the toolbar won’t completely go away but maybe Joplin shouldn’t allow you to shrink the window smaller than a few hundred pixels? I have my data back so I’m good.


Someone else reported an identical situation (and result) a few days/weeks ago. This seems to be related to the mac somehow, it’s probably possible to do as you suggest, but what about the case where the app is spawned off screen? It would be helpful to also understand what about the mac update is causing this.

I can confirm that this has happened to me too.

joplin stopped working on macOS after updating to Catalina 10.15.2
After working properly on Friday, on Monday(today) all of the sudden Joplin is not working anymore.
Not Working means: Joplin Starts, but it is not showing any windows.

So now after reading the above post, I paid attention and I saw a 1 pixel window at the bottom right corner. I managed to drag it to the center of the screen and to enlarge it.

Now everything seems to work just fine.

1 Like

I have this problem, too. I am running macOS 10.15.3 (Catalina) and installed Joplin (1.0.193) via homebrew (2.2.10). No UI visible.

Edit: I read @neum’s post above and checked the bottom left of my screen after opening the “About Joplin …” window and closing it again. There was a tiny one pixel vertical line there. Clicking on it opens up a shrunk window which you can then maximise.

@moontan, is this useful to you? Also, have you attempted to do it without using Homebrew? Several alternative methods for installing that aren’t created by the Joplin team directly have been having various issues being ran across multiple platforms.

Thank you @bedwardly-down! That was a very fast response.
I had a new finding and made some progress before I could read your response and edited my post accordingly. I can see the UI now.

1 Like

Glad you resolved it. Being super fast doesn’t always mean super useful. Ha

1 Like