Are you on a company network? This error often occurs when a company is inserting its own private TLS certificates into the certificate chain so it can read and monitor your HTTPS traffic. As Joplin uses its own certificate authority store it does not recognise these certificates and the connection errors.
I doubt that it would be Dropbox as the certificate is "self-signed" and not by a recognised certificate authority. It would be a bit scary if somehow your ISP was doing this.
Could it be that your Anti-Virus / Internet Security software is responsible?
I do not know if this works for this kind of TLS error but there is an option in the settings to "Ignore TLS Certificate errors"