Joplin upgrade sync failed linux

I'm on Linux (Ubuntu 20.04) and hadn't taken a note of what version of Joplin was installed but now the upgrade has failed and I can't find the exact version because the app doesn't load. It looks like it was going from 1.5 to 1.7 or from 15 to 17 because there are directories with those names on my computer.

I'm syncing with DropBox.

It told me it was doing the update and the next time I looked it had the following message:

request to failed, reason: unable to verify the first certificate

FetchError: request to failed, reason: unable to verify the first certificate
    at ClientRequest.<anonymous> (/snap/joplin-desktop/17/linux-unpacked/resources/app.asar/node_modules/@joplin/lib/node_modules/node-fetch/index.js:133:11)
    at ClientRequest.emit (events.js:310:20)
    at ClientRequest.EventEmitter.emit (domain.js:482:12)
    at TLSSocket.socketErrorListener (_http_client.js:426:9)
    at TLSSocket.emit (events.js:310:20)
    at TLSSocket.EventEmitter.emit (domain.js:482:12)
    at emitErrorNT (internal/streams/destroy.js:92:8)
    at emitErrorAndCloseNT (internal/streams/destroy.js:60:3)
    at processTicksAndRejections (internal/process/task_queues.js:84:21)

I have other laptops (Mac) also syncing but I'm on the train and don't have access to that one to see if it is also failing.

Any help would be much appreciated. I can't really find any clues in the message that might show me what the problem is. Also can't find a way to retry the upgrade.

unable to verify the first certificate

If you are on a train, maybe it's something that the train wifi connection is doing?

Since it's the snap version, you could run sudo snap revert joplin-desktop, this would drop you back to the previous installation and also revert the state of the databases (e.g, settings, notes, etc) to how they were before the update. Probably best to make a backup with an export somewhere outside the snap at this point just in case.

However the error in general looks like Laurent suspects, the train WiFi was likely interferring with the synchronisation, so assuming it's been long enough and you've come off the train hopefully it's working now?

Being unable to verify the certificate, especially in the case of Dropbox which would be properly set up on their end, is Joplin telling you there's something suspicious going on and the network you're on isn't safe or functioning properly.

Thank you to Laurent and James! It seems like it was something to do with the train wifi. When I got off the train I went to Joplin on my phone (4g) and tried to access it there, at which point it told me to update so I did. That was successful and then I refreshed it on my laptop later and that then worked as well. So all is good now. Thank you.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.