Cannot install Joplin Desktop on old Dell Laptop running Ubuntu 18.04

Hi there! First off, as a user of apps like Joplin ever since I started out in Software Development (in the late eighties, starting with Borland Sidekick and another one with notebooks and tags I can’t remember), let me say that after using Evernote for several years, and afterwards Simplenote, I had the good luck of stumbling upon Joplin in a blog post State of Markdown Editors 2019 just a few days ago and haven’t stopped using Joplin since. Will make some posts on how I’m using it at another time.

I successfully installed Joplin Desktop on a MacBook Air (running Catalina, no less!) and then, enthused, attempted to install it on an old laptop (32 bit Dell Latitude E5400) using the method suggested in the docs:

 wget -O - | bash

Everything went ok, but I got a message saying that the desktop icon had not been installed (identical situation to Cannot install in Linux Mint 19.1 Mate, which gave me hope). I followed the instructions there, and the icon got installed, but when I click it, nothing happens (no disk activity).

Laptop (32 bit) characteristics:

$ uname -a
Linux nora-Latitude-E5400 4.15.0-72-generic #81-Ubuntu SMP Tue Nov 26 12:19:40 UTC 2019 i686 i686 i686 GNU/Linux
$ cat /etc/issue
Ubuntu 18.04.3 LTS \n \l

(Joplin terminal application is up and running fine on this system, but I would love to have the desktop app running).

Thanks so much for Joplin!!

1 Like

FWIW it runs fine for me on 64-bit Ubuntu 18.04

Perhaps you can try starting the desktop app directly and see if there are any error messages:


Joplin does not run on 32-bit Linux.

1 Like

Joplin terminal is running fine:

Latitude-E5400:~$ which joplin
Latitude-E5400:~$ joplin sync
Synchronization target: Dropbox (7)
Starting synchronization...
Fetched items: 1/1.
Downloading resources...
Updated local items: 1. Fetched items: 1/1. Completed: 22/12/2019 08:30

But when I execute the desktop binary, it’s clear @tessus is correct!

Latitude-E5400:~$ tree .joplin
└── Joplin.AppImage
Latitude-E5400:~$ .joplin/Joplin.AppImage 
bash: .joplin/Joplin.AppImage: cannot execute binary file: Exec format error

OK, so I have the desktop on my Mac working great, and the terminal version (installed via node 8 (last chance for 32 bit)), which, apart from working fine, once Web Clipper extension was installed as Firefox extension, allows me to switch on the server doing a joplin server start and use Web Clipper! AND practice with the API!!

Latitude-E5400:~$ node -v
Latitude-E5400:~$ joplin version
joplin 1.0.150 (prod)

And I checked with another old 32 bit laptop (Dell 1420N that came with Ubuntu, now running Lubuntu (on 18.04)) shows the same capabilities and lack thereof.

Let me take this opportunity of congratulating all of you for the wonderful functionality of Joplin, I’m going to be using it for many, many things, every day, and will see how I can give back to this great community.


Just FYI: Please note that a PR was merged a few days ago that will raise the reqs to node 10 for the cli version.

Absolutely! The old 32-bit laptops that never stop working (jaja) are consigned to be glorified “mozillabooks”. In any case, thanks for the heads up @tessus !

Hi @tessus , I tried following the official instructions for installing the terminal application on a 32 bit Debian but since Node.js 10 is not compatible with 32 bit, it naturally failed.

Could you please tell me how to install the latest support 32bit terminal version of Joplin?

Unfortunatately I don’t think you can.

We will have to remove those instructions due to the fact what you just mentioned: Node10 does not support 32bit, Joplin requires Node10, thus no Joplin on 32bit.

Couldn’t an older release be built? Is there any documentation on how to do this? Could you please tell me the last version which supported 32bit? Thanks!

I have no idea. Laurent should know.

I am running Joplin terminal on Ubuntu 18 32-bit. It’s syncing just fine with my desktop instance running on my Mac

joplin version
joplin 1.0.150 (prod)

There may be a newer version that still works on 32-bit, but this is the version I’m using, and it’s running fine on an up-to-date Ubuntu 18 on my old Dell 32-bit laptop


Thanks! Would you know how to install it since the official instructions only pull the latest version?

Not 100% sure, but my best guess would be to follow the regular npm syntax for installing a specific version. The official Joplin instructions say:

NPM_CONFIG_PREFIX=~/.joplin-bin npm install -g joplin
sudo ln -s ~/.joplin-bin/bin/joplin /usr/bin/joplin

To see all possible versions of the joplin package, we can do:

npm view joplin versions
[ '0.8.40',
  '1.0.164' ]

Now, we have to simply specify a version (see this Stack Overflow page):

NPM_CONFIG_PREFIX=~/.joplin-bin npm install -g joplin@1.0.150
sudo ln -s ~/.joplin-bin/bin/joplin /usr/bin/joplin

Haven’t actually tried it, my best advice, please let me know if it works or not.

Sorry, but why don't you install 64-bit ubuntu on your dell-laptops? If I'm not mistaken, they must have 64-bit processors installed.

P.S. Sorry for my english

Nope, 32-bit Dell inspiron 1420 over ten years old and even some 32-bit Lenovo processors...

Any specs I have seen for that model show it as having a Core 2 Duo CPU which, apparently, are 64-bit processors.

Check your CPU, you may be able to get another 10 years out of your computer :slight_smile:

Nope, Intel Centrino Series N! dual core, but not 64-bit (64-bit ubuntu won't run on it, only Lubuntu). My original frustration was, precisely, that I couldn't run 64-bit apps of any kind :frowning: I must admit I use my old laptops for servers of various kinds (go based utlities such as Gitea... with kind linux386 distributions)