Home / GitHub Page

In Ubuntu, Joplin Icon does not appear in Workspace

Hello guys,
I’m using Joplin latest versions in Mobile (Android) and Desktop (Ubuntu 18 Workstation).

In desktop app the icon isn’t appearing anymore (after the needed upgrade of version) and in order to start the Desktop App I need to use the command “./.joplin/Joplin.AppImage” and maintain the terminal window opened.

Is there a way to have the desktop icon working normally again?

(I already see another post discussing about it, but honestly I did not understand the best alternative to solve this issue)

Is it the same issue?

https://github.com/laurent22/joplin/pull/2479

Hello, @laurent, I read at least 4 times the link you posted. Tried to rerun the “Joplin_install_and_update.sh” in hope that the change you merged had some new effect but actually nothing different happened.

Can you give me some more advice? It seems a very well known problem, otherwise you wouldn’t say to me to run Joplin-desktop from terminal with this command:
./.joplin/Joplin.AppImage

@BrunoCampana, I think issue #2479 has been fixed and the fix will be included in the next release.

You can check the release notes to see when features and fixes are released.

Release notes are published here and here.

So if #2479 describes your issue, the next release should fix it.

Thanks @mic704b . I saw your posts and it really seems that the issue was fixed. But I do have the last release, and the issue still exists.

If you run the script from git master, it should work.

wget -O - https://raw.githubusercontent.com/laurent22/joplin/master/Joplin_install_and_update.sh | bash

If it doesn’t, you hit another problem.

Thank you again @tessus !
I already tried… Nothing has changed :frowning:

The Desktop Icon in Ubuntu doesn’t work and the only way I have to start the app is executing the command ./.joplin/Joplin.AppImage
from terminal.

@BrunoCampana

Could you try the following commands and post the outputs:

ls ~/.local/share/applications
cat ~/.local/share/applications/appimagekit-joplin.desktop

Thanks again @mic704b :

ls ~/.local/share/applications
Output:
appimagekit-joplin.desktop chrome-hmjkmjkepdijhoojdojkdfohbdgmmhki-Default.desktop
appimagekit-nuclino-desktop.desktop chrome-mjcnijlhddpbdemagnpefmlkjdagkogk-Default.desktop
chrome-aohghmighlieiainnegkcijnfilokake-Default.desktop chrome-nmmhkkegccagdldgiimedpiccmgmieda-Default.desktop
chrome-aohghmighlieiainnegkcijnfilokake-Profile_1.desktop chrome-nmmhkkegccagdldgiimedpiccmgmieda-Profile_1.desktop
chrome-aohghmighlieiainnegkcijnfilokake-Profile_2.desktop chrome-nmmhkkegccagdldgiimedpiccmgmieda-Profile_2.desktop
chrome-apdfllckaahabafndbhieahigkjlhalf-Default.desktop chrome-pjkljhegncpnkpknbcohdijeoejaedia-Default.desktop
chrome-apdfllckaahabafndbhieahigkjlhalf-Profile_1.desktop chrome-pjkljhegncpnkpknbcohdijeoejaedia-Profile_1.desktop
chrome-apdfllckaahabafndbhieahigkjlhalf-Profile_2.desktop chrome-pjkljhegncpnkpknbcohdijeoejaedia-Profile_2.desktop
chrome-blpcfgokakmgnkcojhhkbfbldkacnbeo-Default.desktop mendeleydesktop.desktop
chrome-blpcfgokakmgnkcojhhkbfbldkacnbeo-Profile_1.desktop mimeapps.list
chrome-blpcfgokakmgnkcojhhkbfbldkacnbeo-Profile_2.desktop mimeinfo.cache
chrome-dgbimgjoijjemhdamicmljbncacfndmp-Default.desktop

cat ~/.local/share/applications/appimagekit-joplin.desktop
output:
[Desktop Entry]
Encoding=UTF-8
Name=Joplin
Comment=Joplin for Desktop
Exec=/home/campana/.joplin/Joplin.AppImage
Icon=joplin
StartupWMClass=Joplin
Type=Application
Categories=Office;
1.0.179.940

I had a similar problem after running the install script.
I had the .desktop file in the right place, but it didn’t appear on the desktop.
For me marking the file as executable solved it. (I navigated to it in the file manager and tried to execute the .desktop file, then I was asked to mark it executable in order to run it.)
Hope this helps maybe.

Something went wrong. The script from git master would have created a file with a different last line.

The last line would have looked like this:

#1.0.179.940

So for some reason you did not use the correct install script.

3 Likes

Hi @PeterL would you mind be a little bit more specific to help me? I did not find the “.desktop” file in the Ubuntu File Manager.

Sure.
if using the console you can just do:
chmod +x ~/.local/share/applications/appimagekit-joplin.desktop
with the file manager (i use thunar, from xfce desktop. But should be similar):

  • under view you need to tick “show hidden files”
  • the in the home directory (among others) the .local folder should appear
  • navigate there and through to .local/share/applications
  • double click the appimagekit-joplin.desktop

But as tessus mentioned your file is seamingly different. I would try add the ‘#’ in front of the last line with the version number, this may be an additional problem

2 Likes

FINALLY THE PROBLEM WAS SOLVED THANKS TO @PeterL !!!

I added a hashtag as you said and clicked the file and suddenly the Icon appeared!

1 Like

Howdy, love Joplin on Windows 10 and Android. However, now I’m trying it out on BunsenLabs GNU/Linux with Gnome, and the installer isn’t working. There is no desktop file, I have made the appimage file executable, and get this message:

13396:0214/104939.592432:FATAL:setuid_sandbox_host.cc(157)] The SUID sandbox helper binary was found, but is not configured correctly. Rather than run without sandboxing I’m aborting now. You need to make sure that /tmp/.mount_Joplin0WO6WV/chrome-sandbox is owned by root and has mode 4755.
Trace/breakpoint trap

I’ve tried to run it with --no-sandbox but that has not worked either.

Any ideas?

WIth appreciation,
Miguel Guhlin (@mguhlin)

BTW, in case you’re curious:

appimagekit-joplin.desktop mimeapps.list mimeinfo.cache

and

[Desktop Entry]
Encoding=UTF-8
Name=Joplin
Comment=Joplin for Desktop
Exec=/home/mg/.joplin/Joplin.AppImage
Icon=joplin
StartupWMClass=Joplin
Type=Application
Categories=Office;
#1.0.179.940

Woohoo, this is resolved by fixing SUID error. Here’s the command:

sudo sysctl kernel.unprivileged_userns_clone=1

That allowed Joplin to start up without issue and no sandbox errors were given.

Thanks for listening,
Miguel Guhlin

Thanks @tessus, this fixed my issue.

i just installed right now Joplin on Ubuntu 20.04 and i had the same issue.
the .Desktop file is created and here it is (cat ~/.local/share/applications/appimagekit-joplin.desktop):

[Desktop Entry]
Encoding=UTF-8
Name=Joplin
Comment=Joplin for Desktop
Exec=/home/alain/.joplin/Joplin.AppImage
Icon=joplin
StartupWMClass=Joplin
Type=Application
Categories=Office;
#1.0.216.2188

if i run the app in terminal using /home/alain/.joplin/Joplin.AppImage, everything works well.

I use KDE as DE.
and in fact, desktop icon is not save in the correct directory. under KDE, it should be saved into ~/Desktop

However, the path for app icon is not updated too under KDE. After 2 modifications to the .Destop file, a desktop app launch with icon is on my desktop as it should be.

Here is the .desktop file content:
[Desktop Entry]
Encoding=UTF-8
Name=Joplin
Comment=Joplin for Desktop
Exec=/home/alain/.joplin/Joplin.AppImage
Icon=/home/alain/.local/share/icons/hicolor/512x512/apps/joplin.png
StartupWMClass=Joplin
Type=Application
Categories=Office;
#1.0.216.2188

@laurent: I would suggest (at least for KDE) to create/check a menu item for KDE, in order to make it cleaner (i’m not a fan of Desktop icons) :smiley: I know the 2 parameters are available Type=Application
Categories=Office;

but under KDE there is no menu entry created during installation.