Being dim again! How to select multiple notes to create a list with the Combine Notes plugin

Folks - I'm dropping in and out of Joplin - using EN alongside while I transition but today, for the life of me I cannot see how to select multiple notes to create a list with the Combine Notes plugin.

I am being dim.

None of the conventional keystrokes seem to work - CTRL-click, SHIFT-click, SHIFT-drag etc.

What am I doing wrong?

Thanks for guidance (I've looked in all the keystroke lists I can find - this particular action does not seem to be covered and the info with he plugin does not tell me how to actually select multiple notes!)

UPDATE: I just thought I'd play with the Note Overview plugin and updated the version I had but it now asks me to update Joplin. However, Joplin says there is no new version to upgrade to ... ?????????????


Regarding plugins "updating" to a non-compatible version, this is a known and reported bug.

If you want to go back to using Note Overview with the current release version (1.7.11) rather than using the latest pre-release (1.8.1), quit Joplin, delete the plugin's JPL file out of the .config/joplin-desktop/plugins directory, go to GitHub for the older plugin, download the older version, place it in the plugins folder and start Joplin again.

For me, using Joplin 1.7.11 and Win10, CTRL & left-clicking allows several individual notes to be selected, whilst SHIFT & left-clicking allows a block of notes to be selected.

Right-clicking on that selection allows you to then combine the notes, or you can use the dedicated button that appears in the note viewer pane. A "Combined Notes" note is then created containing the contents of all the selected notes. By default the "source" notes are not deleted unless you select that action in the plugin's settings.

2021-04-09 12_54_25-Window

1 Like

Great - thanks for the plugin issue - that works now ...

BUT for some reason I can't figure why CTRL-left click doesn't work on my PC (though you confirm for me that it should work!) ... using same v of Joplin ... but no joy!

CTRL-left click works as it should elsewhere ...

UPDATE: reinstalled Joplin ... no change ...

This note select method is a basic Joplin feature. Has it ever worked for you?

Personaly I would first try to ascertain where the problem is.

I would make a JEX export of all my notes (insurance!!). Then fully quit Joplin, then rename the joplin-desktop folder to something like xjoplin-desktop. Then restart Joplin. Joplin will open as a new install. It will create a new joplin-desktop folder and default notes. This will have a new and clean database, no plugins, no sync settings and no customisations.

Does the CTRL + left-click etc now work?

  • If it does it may suggest that something in the way you have Joplin or any plugins configured is causing the problem and requires further investigation.
  • If it does not, then I have no idea what could be happening!!!.

Note: To get the original notes and setup back; fully shut down Joplin, delete the newly created joplin-desktop folder, rename xjoplin-desktop to joplin-desktop and start Joplin again.



Thanks for all the advice. After fiddling around a bit more I realised that in fact CTRL-click/SHIFT-click are working but it was just not visible.

I then remembered that some weeks ago I added a userchrome.css stylesheet from here:

This made various changes to the Joplin display which I quite liked ... at the time.

Anyway I removed it and voilá my CTRL/SHIFT-click highlighting is back to normal!

I was using v4.0 of the stylesheet but there is an updated version 5.0 which seems to work fine (but now generates a very similar look and feel to the default display compared with v4.0 which seemed to change a lot of details).

So, I have abandoned the stylesheet altogether because not really needed IMO.

Phew! :sparkler:

Thanks again.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.