Android sync not showing notebooks, tags or images

Operating system


Joplin version


Sync target


What issue do you have?

I have successfully imported everything from evernote to the desktop app - no issues
I have synced to Android using Dropbox - all of the notes are there but the notebook names don't sync nor the tags. Also, NO images are showing in any note

I have tried uninstalling and resyncing a few times with the same results

I am sure this is an easy fix, but this new user isn't sure what to do - thanks

There is no silver bullet, in particular since you say you did un-/reinstall already.
So let's go and get a few more details :

  • sync log from the desktop does not show ant errors, correct ?
  • you have a full backup on desktop ? (just in case)
  • did you try a different sync target (e.g. a free nextcloud cloud drive) ?
  • can you try and sync to a different device (not Android !) ? Even if this was only temporarily, at least we know the whole chain of syncing works.

(I can only respond once every 24h, so please be patient, .... may be sb else reads it).

There are no errors in the sync log
I have everything backed up
I have not tried a different sync target
I don't have anything but android right now

If I were to do another uninstall and reinstall - what should be the order?

FAQ: Not all notes, folders, or tags are displayed on the mobile app

FAQ: How can I check the sync status?

I'd try several options in the following sequence :

  • reinstall Joplin on the Android device (I know you did), sync and check the Android log
  • try to implement a different sync target (temporarily if you like), for example another (old) phone, the phone of a friend (you can always completely delete the profile on that phone)
  • try a different sync target (e.g. nextcloud)
  • when it all fails (let's hope not) follow further instructions on
1 Like

I have done another uninstall and reinstall on android

It seems the issue is that in order for android to sync - the screen has to be active - I have been letting it sync now for hours and it is getting to where it is syncing

1 Like

There are several settings in the Android OS which control whether an app can access the network while in background, among them settings -> wifi -> wifi data usage, and others. And such a setting is not visible in the respective app's permissions dialog.
Check those.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.