Sync problems - no tags, no notebooks, less than all notes, "set the decryption password"

Desktop 2.8.8 (Win 11 Pro), Android 2.8.1
Syncing via Dropbox

I am having problems syncing tags and notebooks to my Android app.

I am an Evernote expat and new to Joplin. I successfully imported my Evernote notebooks, tags, and notes to Joplin desktop. I successfully set up syncing via Dropbox. I successfully synced my notes to my Android (Pixel 6) phone.

However, the notebook and tag structure (which imported from Evernote and is plainly visible in Joplin desktop) did not sync to Android.

Any suggestions on how to get this working? Thank you.

P.S. I have reviewed a few prior posts on this topic but did not find a solution the helped.

take a look into the FAQ Not all notes, folders, or tags are displayed on the mobile app

1 Like

Thanks for that useful link. Although I'm certain I let the mobile sync run to completion (at least twice), it's helpful to know that there is no background sync capability in the mobile app.

Since posting my request, I continued to work on the problem. I cleared some conflicts that appeared on the desktop app, deleted the Welcome notebooks, downloaded a plugin. I rebooted and synced the desktop. Then I rebooted my phone, opened the mobile app and ran the synchronization. I received an error having to do with an encryption lock. I tried again. This time sync populated all the tags and notebooks.

I cannot explain why it worked, but I'm glad it did.

BUT, despite this success, it was only a partial win. The mobile app synced 350 fewer notes than are on my desktop app. And a laptop (which uses the desktop version of the app) has the same number of notes as the mobile app, 350 fewer than the desktop.

Any idea why I'm 350 notes short or why certain notes won't sync to the mobile and laptop?

Thanks again.

And now my Android app has an orange banner that reads ""Press to set the decryption password." Of course encryption is enabled and the master password set. Pressing on the orange banner does nothing and, as far as I can tell, there is no way to "set the decryption password" since it's already been set and working.

Any idea how to get rid of this banner?

How does the encryption screen look? Could you post a screenshot?

Here's the encryption screen from my Android phone.

Not sure what changed but the orange banner has disappeared.

The missing notes are still not loading in Android or on my laptop.

Any ideas on how to get all of my notes to sync across platforms? As it stands, over 350 notes are not syncing to my Android or laptop, even though they exist on my desktop and are syncing to Dropbox.


Today, I was working from home on my laptop and could not find a note that I needed. It is among the 350 that did not sync to my laptop. Because this is an untenable situation, I went into the sync settings and deleted my local data and re-download it from sync target. Once again, the sync completed MISSING OVER 350 notes.

How do I overcome this problem? Or do I just give up on Joplin?

Any assistance is greatly appreciated. Thank you for your time and effort.

Possible your PC has not uploaded the Data. You can try the re-upload local data from the advanced sync options.

Thanks for that suggestion.

The sync status of the desktop PC indicates that the additional notes have been properly synced to Dropbox. Nevertheless, I will do as you suggest and re-upload local data.

Thank you for your help.

Success! Re-uploading the local data from my desktop PC (which was the source of the original sync to Dropbox) prompted my laptop and Android to receive the missing 350+ notes. Thank you @JackGruber!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.