1.1.4 - keyboard locks up while typing

Joplin 1.1.4 (prod, win32)
Revision: 9610b7e6 (master)
on Windows 10, 64 bit Asus desktop

Since I upgraded Joplin yesterday I have noticed that the keyboard frequently locks up for a second or so while I am typing a note.

To be more explicit: I start typing a sentence and notice that the cursor has frozen after some characters have appeared on screen. I stop and wait. A second later the missing text appears at once. This is noticeable enough, and frequent enough, to interfere with the writing process.

This has not happened with previous versions and it is not happening with any other applications on my computer. It is not happening now, while I am typing this, for example. I have not updated Windows in the last week.

Have other people noticed this, or is it just me?


Me too.
It doesn't happen just by moving the cursor, it happens when edit it.Also occurs when move to another note after editing.
I have been suffering from this phenomenon since I upgraded from 1.13 to 1.14.

this issue is seemed to be related to the save process,think to me. So I suspected the OneDrive sync. for that reason, I stopped syncing. But unfortunately it didn't improve.

You are correct. The keyboard also locks up editing an existing note.

yes,I can confirm this happenning too.(Windows 10 pro 64bit/Desktop)

Just to check if it's related to the spellfix extension, could you open database.sqlite in an SQlite browser, then set "db.fuzzySearchEnabled" to "0" in the "settings" table. After you do that, does it make any difference? (after you're done, don't forget to set it back to its original value, probably "1")

Also is there any errors or warnings in the console? https://joplinapp.org/debugging

Also could someone confirm for sure from which version to which version you've upgraded? I assume it's from 1.0.x to 1.1.4 but if different please let me know.

Also what editor do you use? (Markdown or Rich Text)

I've tested a few things on 1.1.4 and for me there's no slow down.

I will do the sql tests tomorrow morning because I am not at that computer at the moment. I will report here when I have done them.

However I can tell you now that the update was from 1.0.245 to 1.1.4 and that I use the markdown editor exclusively. No rich text involved!

Before doing the sql tests I realised there was something else useful I could do. The laptop I am working on now (HP - Windows 10 Pro) had 1.0.245 on it. I upgraded to 1.1.4 - and yes the same problems occur. They do not appear to be as severe, but they are certainly there.

I created a new note. I typed in a paragraph of text. I created a level 2 header. I started to write another paragraph. At the end of this the cursor froze for a smaller but still noticeable period.

I opened the console, following those instructions. After I restarted Joplin it opened with the console visible. The console contained a metre of text. I have put that in Dropbox and, if you want to read it, you can download it from here: https://www.dropbox.com/s/pufabsbpa94zvyf/console-text.rtf?dl=0

I then typed until the input locked, but nothing appeared to be added to the console:

I finally had time to test the settings in the database. Yes it makes a total difference. After I set "db.fuzzySearchEnabled" to "0" the issue disappeared entirely. I typed for two or three minutes without stopping and when I stopped the screen was completely up to date.

A question @laurent - since this has fixed the problem will I suffer any issues if I leave the setting at "0" for the time being? I do not use search much, if at all, in Joplin, at least not regularly, but I do add notes several times a day. If that setting is solely concerned with "fuzzy search" then I can afford to lose that functionality until you have identified the underlying problem. If this will have wider effects then obviously I will set it back to 1.

@MisterKelly, thanks for giving a try and help narrowing down the issue. You can indeed leave the parameter to "0", it simply means that fuzzy mode won't be enabled when doing a search. I'd be interested to know if this definitely fixes the problem for you, or if it comes back, so if it does please let us know.

@naviji, I wonder if there are some issues with the Spellfix extensions? In my case, I managed to corrupt my database while I was investigating this issue by creating many notes. I don't know for sure if it was due to the extension but I thought it could be related. Do you have any idea about all this? In any case, let's wait and see if we can find a solution, otherwise we'll have to consider removing it as stability and performance is crucial.

Thank you!
My Joplin also started working perfectly when I set "db.fuzzySearchEnabled" to 0.
I will continue to use Joplin and report any issues that arise.

Yes, let's remove it for now.

Unfortunately, I'm not able to reproduce it. It seems to be restricted to Windows, though. So probably something to do with how the extension was compiled. I'll try to fix it, but if the problem persists, we'll remove it permanently. Doesn't seem to be worth the effort since most don't find it particularly convenient/useful.

1 Like

I haven't tested that part of the code yet. Is there a way to disable spell checking? e.g. it's the first thing I turn off in all of my applications and in the OS system wide settings.
I would hate for Joplin forcing spell check on me.....

No, it's not spell checking.

Spellfix is an SQL extension that can find similar words using edit-distance. So that slightly misspelled search queries will still give results.

Thanks for clarifying.

yes this fixed it!

Same problem here... laggy keyboard input. Can we get an "disable" toggle for this. I don't want to trash my database.sqlite with faulty editing software (or user error, haha).

Another observation... while typing in the code window, the preview (?) window incessantly flashes (refreshes?). Very distracting. I suspect this is all related. Yes? Or?

+1 on this issue
+1 on the fuzzysearch = 0 fix :slight_smile: