How to fix 'Joplin synchronization slow down keyboard typing' issue?

Operating system

Windows

Joplin version

2.13.15

Desktop version info

Joplin 2.13.15 (prod, win32)

Client ID: 847b324dc209404f9a3327c9368b216e
Sync Version: 3
Profile Version: 44
Keychain Supported: Yes

Revision: 7d2c1c0

embedded tags: 1.0.0
Favorites: 1.3.2
Note overview: 1.7.1
Note Tabs: 1.4.0
Random note: 1.0.3
Simple Backup: 1.3.6
Text Colorize: 1.2.5

Sync target

Dropbox

Editor

Markdown Editor

What issue do you have?

Hello respected forum members:

Following one of my responses to another respected forum member @Yann1ck in a forum thread "How to disable auto sync?", I figured that I should start a new forum thread in regard to the issue "How to fix 'Joplin synchronization slow down keyboard typing' issue?", the issue I am experiencing is also partly shown as below quote (1), I'd much appreciate it if someone shed some light on a solution to the described issue.

(1) The quote: