Micro freezes / stutter when typing

First of all, thank you for this software! I wanted to get rid of OneNote and use it since 2 years nearly every day!


OS: Win10 Pro 64bit 1909
Joplin: portable: 
Joplin 1.0.195 (prod, win32)
Client ID: e7222645626344209454c9f04a2447aa
Sync Version: 1
Profile Version: 28
Revision: f4a562bc (master)


Sync status (synced items / total items)
Note: 453/453
Folder: 50/50
Resource: 41/41
Tag: 7/7
NoteTag: 7/7
MasterKey: 0/0
Revision: 439/439
Total: 997/997


Now for my problem. I am experiencing micro freezes since about 3 to 4 months now with different Joplin versions. I hoped it would get better with new updates, but that was not the case. For updating, I only replace the .exe with the newer portable one and so far, had no problems with it.

So I had an eye on the logfile with tail and used Joplin in parallel. What came to my eye was this entry:

2020-04-01 07:29:26: "Scheduling sync operation...", "30000"

Every time this occurs, the micro freeze (about a sec or two, with no keyboard input recognized) happened.
So I disabled the sync interval and set it to manual. I am syncing to a network share (but also tried a local folder), but the freezes and this log entry are still there.

Any idea, or some more information I can provide for this? Anybody else experiencing this behavior?

It nearly happens every time I fill in or change/delete content in one note, for example here three times in a row:

2020-04-01 07:43:03: "Scheduling sync operation...", "30000"
2020-04-01 07:43:05: "Scheduling sync operation...", "30000"
2020-04-01 07:43:12: "Scheduling sync operation...", "30000"

So maybe someone has an idea? :slight_smile:

Are the notes you’re editing full of katex math? In the last couple versions there were some rendering issues that slowed this down.

So for the most parts, I just use:

- [ ]

` code `
``` code block ```

So I guess, no katex math :slight_smile: . But, I have it enabled it in the plugin options, if this could also lead to these rendering issues?

Enabled is no problem. Sadly I don’t know what your problem could be, hopefully someone else has experienced this and can make a suggestion.


After trying Zettlr, Typora, BoostNote, CherryTree and Joplin, I’ve settled on the latter. I’ve been using it for about a month and it also regularly happens to me. I’m blaming it on the fact that I run the portable version on a SD card (on which I have PortableApps installed), so the database is stored on this very SD card next to the application. I also use it on another computer but on the main SSD drive and don’t have this problem.

This being said, the purpose of portable apps is to be able to carry them around on a portable storage device (besides not putting any file in the system folders), and these freezes make Joplin pretty unusable under these conditions. I noticed that these freezes occur when the SD card activity led is lit, and this led tends to light up when I type something. So I guess it has to do with on-the-fly saving of what is being typed and the fact that the storage device is not very reactive.

It is just weird that typing a few character triggers such intense storage activity. If this is the explanation, can’t the auto-save operations be performed asynchronously in a separate thread to avoid freezing the app until the data is written to the file?

Otherwise, any clue for fixing this behavior, like something to change in the application settings, is welcome…

Hi Patrick,

just for you to know - I use the portable version because of lack of administrative rights for installing the native version.
But! I do use it on an SSD drive, not an SD card. And I guess (and hope), that this should be fast enough :slight_smile:. The interesting part for me is indeed, that this could - just could - be a problem of the portable version. Interesting question thought, regarding the asynchronous write.

My question would be, the "scheduling sync operation" log entry, is this for writing changes to the textfiles on disk, or is this the sync operation (that I thought I had deactivated).

I think somebody mentioned in another topic that this might be related to Electron and that a newer version might fix this.
I don’t have Windows, so I can’t create a test build. But somebody could try to upgrade Electron and create one.

If you do upgrade Electron, you’ll probably need to upgrade node-sqlite3 to the master branch. It involves passing npm install node-sqlite3@git://github.com/mapbox/node-sqlite3.git or a variation of that in the ElectronClient directory. You’ll also need to upgrade node-abi and only Electron-8.0.0 is currently supported by node-sqlite3

Is there anything I can do to help out?

Because I am not the owner of the windows pc I am using with Joplin, I am afraid I have to wait for an "official release" of the portable app anyhow.

Or is it possible to downgrade the portable version? Then maybe I could just use a version from last year. The bug is kind of a real bumper :slight_smile:.

And by the way - thank you to all that replied!!

Just wanted to drop by to let you know that the freeze problems disappeared with .216!
Maybe it is because of

Improved: Upgraded to Electron 8.2.5


So I think this thread can be closed :slight_smile:.

1 Like