Windows update failed and now I can't open, reinstall or uninstall


Hope you are not infected or otherwise hurt by the Corona virus. Only help when okay, please.

I tried to update to Windows version 1.0.199 from 1.0.179.
Installation failed at some point because a file could not be found, openend or something (sorry I don't remember. I told the screen to ignore to see what should happen.

After that I can't open Joplin anymore at all, because the link is not recognised.

  • I can't reinstall: the procedure says, after I gave administrator rights to proceed, that it is stopped and can't be finished. I'm sorry I can't give you the proper line, I'm trying to translate the Dutch messages.
  • I can't uninstall, because uninstall.exe is not found in the appdata folder. By the way, the old ánd the new version are both in the uninstall settings list. I included two screenshots.

Is this a log you can do something with? **log-autoupdater.txt (16.4 KB) **

I really hope you can help get further exploring Joplin. I am starting to like it... :wink:

Kind regards,



Please give this a try:

Hi Laurent,

Thank you for trying to help and sorry I didn't respind earlier. In the ninetees friends thougt i could solve everything on pc's, and I am still struggling to admit I can't. :wink:

And I can't. Im sorry to say your proposed solution didn't do the trick. I tried several other things like cleaning my entire register with CCleaner, remove folders with anything Joplin, of course re-download the install file and a lot of restarting, still on HDD, grumpf, but nope. Installation stops 1 second after giving permission (install as administrator) with the notification Installation stopped, as I aaded in the first cry for help.
Can yoy, or some body else ofcourse, advice me something different (I don't have money to buy a deep delving uninstaller...).

Hmm, yes that’s annoying as I thought the above fix should work. It would clear the invalid keys and allow reinstalling.

Another way in that case is to use portable release, but it will mean more manual work to update the app. You simply drop JoplinPortable.exe in any folder and it will directly without installation, creating the profile in a JoplinProfile directory next to the executable.

Hi Laurent,

I’m having a similar problem, which started when I tried to upgrade from 1.0.200 to 1.0.201. The installation froze, and wouldn’t finish when I tried to run it again. I’m new to Windows, so I tried uninstalling Joplin through “Add or remove programs,” which I see now may have been a mistake on my part.

I did try also deleting the entry from the registry, and when I ran the installer again, I got this error:
“Error opening file for writing: C:\Users(name)\AppData\Local\Programs\Joplin\Uninstall.exe. Click Abort to stop the installation, retry to try again or Ignore to skip this file.”

I just downloaded the portable release - where should I put the file to avoid issues if this problem is resolved in the future and I can return to the regular release, so I don’t have to update manually?


Just an update to say my problem appears to be fixed - I was able to automatically upgrade from 1.0.200 to 1.0.201 via Joplin. I installed a BIOS update and updated my version of Windows.

Hi Laurent,

Sorry again for my slow response, lot of other nice things to mind.

Pity, we cannot solve this, but I’ll try the portable version.

Giving Windows a complete overhaul is a bridge to far for me now.

Kind regards,

I was having the same problem, what solved it for me was: -first, i followed laurent and deleted the folder in regedit
-second, i installed the app using "run as administrator" option and it worked!