Cannot install joplin. (error opening file for writing)

I downloaded Joplin installer from Downloading Joplin... | Joplin.
I am getting this issue

I ignored it and it installed successfully but the created desktop shortcut links to nothing.

For other support queries please indicate:

  • 2.5.10
  • Windows

@Trex welcome to the forum.

For some reason the download link on the download page has not been updated to link to the latest release version.

Get the latest release version of Joplin (as of writing it's Joplin-Setup-2.5.12.exe) from Joplin's GitHub site.

Otherwise when you get this fixed the first thing Joplin will do is prompt you to upgrade!

Also, just in case the failed install has left anything locked try rebooting Windows before trying the install.

If this does not work there are a few initial questions just to try to determine what is happening here :slight_smile:

  • You state you are using Windows. Which version and is it 32-bit or 64-bit?
  • Please confirm that when installing you selected the option to install for "Anyone who uses this computer (all users)" as this installs Joplin into "Program Files" rather than the user's folders.
  • Your "Program Files" folder is showing as being on your E drive not your C drive, is this correct?
  • Is the E drive an internal hard disk / ssd?
  • Do you actually have write permissions for that drive / folder? Can you browse E:\Program Files using the file explorer and create a folder (Right Click > New > Folder)?

Thanks for the reply. I installed it by running it as Admin and that fixed it. But i think it should also work without running as admin as I am installing for one user.

Glad it's working...

If installing for all users there will be a User Account Control (UAC) admin prompt which allows an installation to Program Files. If the option to install "Just for me" is selected Joplin is installed to C:\Users\<username>\AppData\Local\Programs\Joplin\ without needing a UAC dialog.

If you need to actually run the installer using "Run as administrator" I can only assume that it is related to how your system is configured.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.