Can't install on windows

I am unable to install Joplin on my Windows 10 PC. Each time I run the installer it gets about 30% done then aborts saying:

Installation Aborted
Setup was not completed successfully.

Installer is Joplin-Setup-1.0.197

Hi, I don’t know if it’s any help to you, but I tried Windows portable app and it works fine.

Did you try turning your computer off and on again? In Windows if a previous installation has failed, other installations might fail too till you restart.

I did try turning it off and back on again but it still won’t install. Drats! I checked the install dir and it’s not there, so that doesn’t need to be cleaned up. Anything else I should check for manual cleanup?

You’re right, portable does work just fine. For all practical purposes, that settles it. But now I’m just curious/determined/frustrated about the ol’ installer!

The IT Crowd. Brilliant.

1 Like

You could try having a look through the locations mentioned in this post.

These are the locations Joplin uses when installed for "current user only".

@aday, I don’t know if you fixed it, but I got the same issue today on Windows, and I’ve added a FAQ entry on how to fix it:

It seems it’s due to that change recently introduced in electron-builder:

1 Like

I’d given up and was just using the portable version (which is fine) - thank you though, I’ll give this a go this weekend!