Windows client cannot connect to webdav via proxy

Operating system


Joplin version


Desktop version info

Joplin 2.14.20 (prod, win32)

Client ID: 983f991ce5084e40a4203a762aea206c
Sync Version: 3
Profile Version: 46
Keychain Supported: No

Revision: cfd98e3

Sync target


What issue do you have?

Joplin Windows app cannot connect to webdav via corporate proxy with the error:
request to https mydomain/webdav/joplin/ failed, reason: Proxy timeout

On the other hand, the following curl command is working:
curl --proxy mycorporateproxy:8080 -u mywebdavuser:mywebdavpassword --basic -X PROPFIND -H 'Depth: 1' https mydomain/webdav/joplin/

In the browser it is working as well for the URL: https mydomain/webdav/joplin/

Also on my home Windows laptop it is working as there is no need of proxy.
And on my Android it is working.

I've tried different combinations of Proxy URL:
http mycorporateproxy:8080
https mycorporateproxy:8080
http theipaddresofmycorporateproxy:8080
https theipaddresofmycorporateproxy:8080

Other params:
WebDAV URL: https mydomain/webdav/joplin/
WebDAV username: mywebdavuser
WebDAV password: mywebdavpassword
Proxy enabled: true
Proxy timeout (seconds): 10

Could you please give me the hints how to solve this?
P.S. the names that I used are not the real ones: mycorporateproxy, mywebdavuser, mywebdavpassword, mydomain.

Let me answer myself.
The following link helped me (unfortunately, the link is not allowed):
github dot com / laurent22 / joplin / issues / 164
"Synchronization does not support proxy #164"

I created Joplin.cmd command file with the following content:
set http_proxy="http colon slash slash mycorpproxy:8080"
set https_proxy="https colon slash slash mycorpproxy:8080"

So when I start Joplin by running this command file, the proxy starts working.

1 Like