Why aren't my url's clickable

I love everything about Joplin, except the editor. I add links (in either editor) and no matter which editor/viewer I use they are not clickable. It is so annoying. I also don't understand why there are two buttons to toggle editors. Seems like one button would make it less confusing.

Two buttons are required as there are two different editors:

  • Markdown editor which is for directly writing markdown formatted text which comes with 3 layouts - editor, rendered and split (which is just the first two on one window so you can write and preview at the same time) which is why you have the layout button to swap between them. This is more like writing in a text editor with some helpful buttons to assist with formatting.
  • Richtext/WYSIWYG for writing as you would with a word processor where you don't see any formatting characters - but they are still there in the background. As you see your rendered output as you type there is no need for the second button to be highlighted.

More info here - About the Rich Text editor | Joplin

URLs in the markdown editor preview should be clickable like normal. URLs in the richtext editor should work if you ctrl+click (not sure if this is ctrl or cmd on mac) which is a fairly standard convention in such applications to avoid going to a website by accident when you instead want to edit it.

1 Like

The OP may be experiencing the same problem I have had (see https://discourse.joplinapp.org/t/links-get-converted-to-text-when-using-wysiwyg-editor/20544). Basically, unless you set a custom text for an URL, the Richtext/WYSIWYG seems to automatically convert it to text, stripping all formatting and making it non-clickable in the process.

1 Like

I can't seem to replicate that in 2.5.1. If I create links in the richtext edtior and migrate to and from the mardown editor nothing seems to get altered or changed.

It does seem that you are right in that if you try to enter the same data into the text to display field as is in the URL field, it doesn't apply the specific markdown URL formatting.

  1. URL and display differ
  2. URL and display the same
  3. URL, display and title the same
[www.google.com](http://www.google.com)
https://www.google.com
https://www.google.com

One small workaround is if you put an extra character (or just something other than null) into the title line then it does apply the full markdown format even if the first two fields are the same:

[https://www.google.com](https://www.google.com "https://www.google.com-")

However I can't seem to get the links to become non-clickable (Win10, 2.5.1), no matter what choice of editor I pick and swap between I cannot replicate it (I also tried in 2.3.5 but can't make it do it there either)

1 Like

After more testing, I can confirm. If you add links using markdown with proper formatting, they stay untouched. However, if you add them using the richtext editor with the same content for the URL and display, they appear to be a link and are actually clickable at first, but if you switch to markdown, you can see that there is no formatting there, only text.

This is a good one, which I haven't thought about. I personally don't care for the title, I just want the link to remain link, and not text. It seems that even a single space set as a title does the job :slightly_smiling_face:.

I tried this but I cannot replicate it. I pasted http://www.google.com into the richtext link inserter tool thing and it works just fine. It is unformatted text but the richtext editor is still recognising it as a link (on the fly) for me, it retains the highlighting and ability to ctrl+click to follow. I tried following the steps from your post but I can't seem to replicate in either 2.3.5 portable or 2.5.1 (both Win10). In none of my previous tests did I start from the markdown editor, always from the richtext editor.

Do you have Linkify enabled?

image

Without this one, the links are display as non-clickable text. I normally use Joplin with all plugins disabled.

Ok that makes more sense. Unless some other kind of metadata is stored against the note, the content put into notes.body is the same so what I assume is that the richtext editor is essentially running some equivalent of linkify whilst the note is loaded which obviously cannot recognise it once it is reloaded.

To me I think this would count as a bug or at least an unintended feature as its behaviour is different from the markdown editor equivalent of the same feature which inserts the proper markdown formatting.
Essentially doing this:
image
Should result in
[https://www.google.com](https://www.google.com)
and not
https://www.google.com
even if the URL and text to display fields match so that a proper clickable URL is preserved no matter what application or editor you are using.

I've reported the issue on GitHub. I hope it's fine with you to use your screenshot for demonstration.

Is there any way I can make the Markdown editor URLs clickable?

For example I would like to let Joplin recognize https://www.duckduckgo.com in

[my link](https://www.duckduckgo.com)

as clickable, and actually open it by CTRL+left mouse or something else.

Note: I t mean the plain Markdown eidtor, not the Rich/WISIWYG one.

There's Rich Markdown plugin that does this, among many other things.

This plugin was exactly, what I have been searching for. Thanks for the hint!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.