Web clipper dialogue not displayed on Firefox (Win 10)

Windows 10 22H2, Firefox 112, Joplin 2.9.17.

Clicking on the web clipper icon doesn't display the clipper dialogue box, as shown here:
2023-04-14 12_05_16-Home - BBC News — Mozilla Firefox

You can see the very top of the dialogue if you look closely.

It has been working up until a Windows update and a Firefox update, although I cannot remember if the clipper stopped working immediately after either of these updates. I have disabled all other Firefox addons, restarted the browser, restarted the laptop, restarted Joplin and disabled/re-enabled the clipper addon, all to no effect. It seems a strange problem and I wondered if anyone else had encountered it and hopefully found a solution.

Is this the similar bug as this one?

Brilliant, that's exactly it, thank you. Setting privacy.resistFingerprinting to false makes the web clipper dialogue visible again.

Looks like I'm suffering the same issue... Can anyone tell where's the user.js file the post is talking about? Is this a Firefox or Joplin settings file?

Thanks in advance for any help!

It's Firefox, but I believe that you would have had to have manually switched this setting on for it to be a problem.

Anyway, to check type about:config in the URL bar at the top of the Firefox browser and press enter. Acknowledge the warning. Search for privacy.resistFingerprinting and ensure that the value is set to false. The two-way arrow to the right will let you flip the value if needed.

EDIT: Beaten to it by dpoulton! See screenshot below:

1 Like

Thanks guys! The value is already set to "false", so what could I do now? In my case, the web clipper only displays "Connecting to the Joplin application" forever. I've already checked that the clipper is activated in Joplin, but its status is "idle". Could it be that Firefox plugin doesn't communicate on the right port? If yes, how can I check this?

I was going to post a link to another thread about a similar problem and then realised that it was your post :slight_smile:

It's possibly better to carry on with your own thread rather than here, which relates to a different problem.

OK, sorry for the cross-post but I'm investigating any solution I can find! Will resume the other thread then but should you have any hint for this, please tell me! :wink:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.