WebClipper does not work with LibreWolf

I am currently using Joplin 2.9.17 (prod, win32) and have WebClipper version 2.11.2 installed on LibreWolf 112.0.1-2. I have also tried using it on Firefox 112.0.1 without any extensions.

However, for the past few days, when I click on the WebClipper button, only a thin gray line appears and I am unable to save any pages. Could you please assist me in resolving this issue?

Thank you for your help

Does Librewolf settings have privacy.resistFingerprinting: true set by default?

1 Like

Yes, it does.

Set it to false

For what it's worth, Joplin Web Clipper also stopped working for me about the same time I activated resistFingerprinting based on advice from an on-line privacy article. Since it was immediately after that I figured there was a connection.

I also happen to own Typora so I've been doing copy/paste to Typora and then from Typora to a new Joplin note. I would certainly be happy if the Joplin Web Clipper worked around this problem but I realize it may not be an easy change.

Another LibreWolf user here, can confirm this fixed it!

I don't understand why privacy.resistFingerprinting: true is required in the latest version (it's not in 2.8.1), it seems like quite the privacy tradeoff if Mozilla's own help-articles is anything to go by:

"Some websites, particularly those using HTML5 Canvas, look at this unique combination of factors and assign you a number, or a “fingerprint”, which makes you identifiable across the Web. This “fingerprint” is potentially used to profile you for targeted content without the use of cookies.

However, the Canvas Permission Prompt is not the only thing that Fingerprinting Protection is doing. Fingerprinting Detection changes how you are detected online:

  • Your timezone is reported to be UTC
  • Not all fonts installed on your computer are available to webpages
  • The browser window prefers to be set to a specific size
  • Your browser reports a specific, common version number and operating system
  • Your keyboard layout and language is disguised
  • Your webcam and microphone capabilities are disguised
  • The Media Statistics Web API reports misleading information
  • Any Site-Specific Zoom settings are not applied
  • The WebSpeech, Gamepad, Sensors, and Performance Web APIs are disabled

(Not allowed to share links, sorry)

I do hope the need to disable fingerprint resistance is reconsidered.

As mentioned in the github issue, it's something you need to report to Mozilla. We didn't break the clipper, Mozilla did, so they need to figure things out. They have millions of dollars from Google to work on such features, we don't.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.