Web Clipper - autocompletion broke

Version 1.4.10 prod Win32
Windows 10 64bit Pro

When trying to clip a web page by adding a tag through the Clipper,the autocompletion stops after typing the first letter or second plus it does not return all available tags.

For example, I have a tag 'Selenium' in my notebook.When on Clipper I type 'Se' it brings other tags but not 'Selenium' while when I type 'Sel' it displays nothing.

I can't replicate this. What version of the web clipper?

Hi Laurent.
It is 1.4.3 of clipper installed from Chrome store

I've update Joplin desktop but the issue remains.:
Joplin 1.4.11 (prod, win32)
Sync Version: 2
Profile Version: 34
Keychain Supported: Yes
Revision: 28f75449d (master)

Should I record a short video showing the issue?

Yes that might help.

Here's the video

and here is the screenshot that shows the tag 'selenium' in Jopplin

reverting back to v1.3.18 , before the Clipper API change, made it work again!

It will be fixed in the next clipper release.

I've just tried 1.5.12 and the issue still persists. Don't get me wrong, I'm not demanding it to be fixed right now!;far from it. It's just that no one else seems to be impacted by it??

Hmm, yes that was fixed but the updated clipper was never released. I'll try to do that at some point.

Is the procedure to release the clipper still the same? If so, I can do it.

If not, maybe you can tell me how, in which case I can do it the next time. After all the changes, I haven't released any new CLI or clipper versions. But if it helps you I'm more than happy to learn how it works again.

Actually yes if you could release it that would be great. Normally you just need to run npm run releaseClipper from the root and it should run the same script as before. The release files should be in packages/app-clipper

Ok, will do.

Worked so far. I received a weird error, which I don't really understand, because the android client has nothing rto do with the clipper....

To github.com:laurent22/joplin.git
   4128c53fc..8ca9c3092  dev -> dev
Fatal error
Error: Command failed: git push --tags
To github.com:laurent22/joplin.git
 * [new tag]             clipper-1.6.1 -> clipper-1.6.1
 ! [rejected]            android-v1.4.11 -> android-v1.4.11 (already exists)
error: failed to push some refs to 'github.com:laurent22/joplin.git'
hint: Updates were rejected because the tag already exists in the remote.

    at ChildProcess.exithandler (child_process.js:308:12)
    at ChildProcess.emit (events.js:315:20)
    at maybeClose (internal/child_process.js:1048:16)
    at Process.ChildProcess._handle.onexit (internal/child_process.js:288:5) {
  killed: false,
  code: 1,
  signal: null,
  cmd: 'git push --tags'
npm ERR! errno 1
npm ERR! root@ releaseClipper: `node packages/tools/release-clipper.js`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the root@ releaseClipper script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

However, the files were created and the clipper tag was pushed, so we are good.

I'll submit the files to the respective stores now.

As always the Mozilla review takes a while.... The new clipper 1.6.1 is already in the Chrome store.

Thanks! I'm not sure why the git push --tags command failed but maybe try again to run it manually to make sure the relevant tags and commits are on GitHub.

I think I found the problem. I believe you might have re-tagged android-v1.4.11 at one point on the remote. Thus the local and remote tags (hash points in the tree) for android-v1.4.11 did not match. I deleted the local tag and pulled it from the remote. All is good now.

Excellent! I've updated the plugin and now everything is working.
Thank you guys!

Hi,the same problem occurs now with Joplin version 2.3.5, Windows 10,Chrome

the same with version 2.4.4.BUT the clipper extension on Firefox works! so it's a chrome extension issue

1 Like


I'm having the same issue.


Joplin 2.4.8 (prod, linux)

Sync Version: 3
Profile Version: 39
Keychain Supported: No

Revision: f3d4d8e


Brave Version 1.30.87 Chromium: 94.0.4606.71 (Official Build) (64-bit)
Clipper: 2.1.3