Unable to set up sync on iphone via dropbox

Iphone 13 Pro
Joblin version 12.8.1
Log shows no errors.

Have set up sync on my mac with dropbox no problem.
When trying to do so on the mobile app, after pasting in the long code from Dropbox, all I get is a white screen on the app that never goes away. I have to kill the app to be able to use it again.

Any ideas?
Thank you.

Is there anything in the log file?

Yes, the log file has tons of lines, longer than I can show with a screen shot, but nothing on the 'error' tab. That's empty.

I would upload a screenshot of just the top of the log file but I don't seem able to attach anything to these replies - is that correct? One can't attach a file?

I can't copy any of the log file on my phone so I don't see any way to share the log file details here. As I said before though - the error tab is completely empty.

I don't think there should be anything stopping you from pasting a screenshot into a reply? Otherwise I guess you can just upload to 3rd party image host.
Ideally if you can provide something that has the timestamps around the time you attempted to sync.

Attachment0.jpeg

Not sure if that has worked? Tried to paste the screen shot that I emailed to myself.

Ok maybe this will work. Have logged in on my phone instead. This is a copy of the text from the screenshot of the log. Thing is ibhave to kill the app after trying to sync as it just goes to a frozen white screen so hopefully this will have something of use.

19:244
Log
06-24T19:24:16: "SearchEngine: Updated FTS table in 4ms. Inserted: 0.
Deleted: O"
06-24T19:24:16: "SearchEngine: Updating FTS table..
06-24T19:24:10: RevisionService: "maintenance: Done in 127ms"
06-24T19:24:10: RevisionService: "collectRevisions: Created revisions for 0
notes"
06-24T19:24:10: RevisionService: "maintenance: Starting.
06-24T19:24:10: RevisionService: "maintenance: Service is enabled"
06-24T19:24:08: "DecryptionWorker: cannot start because no master key is
currentlv loaded.
06-24T19:24:07: "Synchroniser is missing credentials - manual sync required to
authenticate."
06-24T19:24:07: "Updating all notifications..
06-24T19:24:07: "Garbage collecting alarms.
06-24T19:24:07: "Saving updated Dropbox auth."
06-24T19:24:07: "Preparing scheduled sync"
06-24T19:24:07: "DecryptionWorker: cannot start because no master key is
currently loaded."
06-24T19:24:06: "ResourceFetcher: Auto-added resources: O"
06-24T19:24:06: RevisionService: "runlnBackground: Starting background
service with revision collection interval 30000"
06-24T19:24:06: "Application initialized"
06-24T19:24:06: "ResourceFetcher: Auto-add resources: Mode: manual"
06-24T19:24:06: e2ee/utils: "Trying to load O master keys...
06-24T19:24:06: e2ee/utils: "Loaded master keys: 0"
06-24T19:24:06: "Loading folders.
06-24T19:24:06: "PluginAssetsLoader: Assets are up to date. Hash:
ea13a22d0df59339b671f6b5700e2914"
06-24T19:24:06: "Sync target: 7"
06-24T19:24:06: models/Setting: "Applying default migrations..
06-24T19:24:06: e2ee/utils: "Trying to load 0 master keys..
06-24T19:24:06: e2ee/utils: "Loaded master keys: 0"
06-24T19:24:06: e2ee/utils: "Master password is not set - trying to get it from
the active master key..
06-24T19:24:06: "KeychainService: checking if keychain supported"
06-2419:24:06: "KeychainService: check was already done - skipping
Supported:" "O"
06-24T19:24:06: "Database is ready."
06-24T19:24:06: "Loading settings.
06-24T19:24:06: "Database was open successfully"
06-2419:24:06: "Checking for database schema update..
06-24T19:24:06: "Current database version",
"'"version":41 "table fields version":41}"
06-24T19:24:06: "Upgrading database from version 41"
06-24T19:24:06: "New version: 41. Previouslv recorded version: 41"
06-24T19:24:06:
06-24T19:24:06: "Starting application net.cozic.joplin-mobile v12.8.1 (prod)"
06-24T19:23:38: RevisionService: "maintenance: Done in 109ms"
06-24T19:23:38: RevisionService: "collectRevisions: Created revisions for 0
notes"
06-24T19:23:37: "Synchroniser is missing credentials - manual sync required to
authenticate.
06-24T19:23:37: "Preparing scheduled sync"
06-24T19:23:37: RevisionService: "maintenance: Starting..
06-24T19:23:37: RevisionService: "maintenance: Service is enabled"
06-24T19:23:37: "Running background sync on timer..
Refresh
Errors only

For clarity, i click to allow dropbox, i get the long code from dropbox and paste that in to joplin and click submit. Then i get the frozen white screen and have to kill the app.

The app seems to be working fine in every other aspect.

When it freezes is it entirely white or do any parts of the UI still show?

Yes, right at the very top of the screen is this sentence:
"To allow Joplin to syncronise with Dropbox."
Interestingly, the bottom bit is cut off, so the tails of the letters 'p' and y' aren't visible. The full stop at the end, which doens't really make sense given the sentence, could perhaps be a commer, which would make more sense grammatically, but that's all there is. The rest of the phone screen is white.

I'm on IOS 15.5
Hope that helps to understand what is going on.

I'm at a bit of a loss I'm afraid, I've managed to sync to dropbox with the only iOS device I have access to without any issues.
There have been examples of issues on iOS before where white areas of the screen cover show up and cover/hide other elements.
What does it look like if you set the theme of the application to dark? Or try to configure a different sync target (even if it isn't real).

Hi there,
Setting the appearence to dark doesn't make any difference and nothing shows up that isn't visible in light setting.
Choosing One Drive makes the screen go blank as soon as I save.
I can't really test any of the others.
So it looks like it isn't really usable for me on the phone, which is a shame.

Interestingly, I can't create notes either. Get the same thing. White screen with perhaps some text right at the top. Seems that for some reason, this version of Joplin simply doesn't work either on this version of IOS and/or Iphone pro. Such a shame.