Home / GitHub Page

Encryption-Sync Not Working

I encrypted 2.2 G to dropbox. first, I setup the application on my iphone and synced. All of the files show encrypted. I was never prompted for the master key that I setup from my desktop.

Was I supposed to have entered the master key on my iphone before i started the initial sync?

Help! Since I don’t have a personal server, I need to use encryption.

BTW - This tool is GREAT on my desktop! I wish you had a WYSIWG option, but I’m now using typora until the feature is available.

Once I get the encryption working I will be golden.

You need to let sync finish on your phone. The master key is just one file among others and you need to wait for it to be downloaded before your data can be decrypted.

hi laurent,
it’s been like this for three days. The sync has been saying complete since Friday.

Is there any error in the log?

no errors but, i’m receiving the following; DecryptionWorker: cannot start because no master key is currently loaded.

resourcefetcher auto-add resource: Mode always

https://1drv.ms/u/s!AvTaB8w8k6gw8C49EfByJVFlF-bj?e=ORuZT4

Here is a screenshot of the log file from my iphone.

I know this isn’t helpful, but FWIW I’m having the exact same problem.

My setup is Windows>>Nextcloud>>iOS, and iOS isn’t decrypting.

the log are in the setting screen and behind the button “export report”
here your screenshot show nothing :confused:

Same Issue here. Encryption not working after sveral attempts and starting from scratch.

Joplin Portable 1.0.170 Rev. 22c3646f, Dropbox, Start: Desktop Win7 (64) sync to Desktop Win10(64).

Finally I saved all notes to JEX-file. Started from scratch, imported notes from JEX-file, encrypted them by synchronizing them, then moved to the other system. There I also started anew and synct. The result is a bunch of encrypted notes and notebooks but no master key. As of now I gave up and work without encryption and wait if there will be a solution.
However, like to work with Joplin. Keep on coding!

I am having the same issue. Version 1.0.311 on Samsung Galaxy S9 running Android 9. Unfortunately my logs are not showing up after export but the only error I have is attached. I do also have the same encryption worker note about the master key not being found several times in the log. I will try to resync on my computer and report back. Any help is greatly appreciated.

@RadSousa, can you check on your sync target what is the largest file?

@laurent To answer your question, The largest file is called fdd587107fdd4af1afd554866bf2c405.md and is 4 MB. I think that is what you are asking.

I believe I may have spoken too soon. I did get back on my desktop (Ubuntu 19.10) and I see under the synchronization status that is shows the sync is not completed yet. It specifically shows that the encryption key has NOT been synced. So I am waiting to sync that fully and hoping that solves the issue.

I will report back if that resolves the issue but I am hopeful it will. However, I am not sure why the synchronization said it was done on my Joplin desktop app when it was not fully sync’d (as shown by the synchronization status page).

@laurent one question: wouldn’t it be possible to name the key <hash>.key so that it can be retrieved by syncing *.key items first?

A post was split to a new topic: Sync upgrade draft

My issue was indeed resolved by allowing the full sync to occur. I would say to avoid this confusion in the future it would be good to add a similar encryption status page to the mobile app and make it more clear when the sync is fully-completed. In addition, adding some code to make the encryption key the first (or nearly first) item to be synced to a new device once that device detects encrypted data would be a great improvement as well. Thanks and great app!

Okay so I am back having waited 24 hours (as recommended by others in this forum) for the decryption to work its magic. Unfortunately, it only decrypted part of my notes. The vast majority remain encrypted and can’t be accessed. I have tried to transcribe the error I receive to the best of my ability below but there was no way to copy it from the app log that I could find.

12-04T14:50:57: "DecryptionWorker: ", “{“message”: “Row too big to fit into CursorWindow requiredPos=81, totalRows=82”,“code”:0}”

1 Like

What’s your largest .md file on the sync target?

@laurent It is named fdd587107fdd4af1afd554866bf2c405.md and is 4.2 MB.

I had similar problems with encryptation and sych. Desktop with Linux Mint and Android Device. What I did was to export the data on desktop to .jex, set up a new, empty Joplin Installation there with only one note and encryptation enabled. When I synched with a new empty Installation on Android I got the encryptation key right away. Reimport from .jex on Desktop, sychronize -works.

even though I get no error message, I happen to have the same problem on my Android device, synced with Nextcloud via WebDAV. Just 32 out of 300+ notes are decrypted, can’t understand why!