Unable to decrypt items on mobile devices after update Joplin 2.11.11 (prod, win32)

Joplin 2.11.11 (prod, win32)

Client ID:
Sync Version: 3
Profile Version: 43
Keychain Supported: No

Revision: 6886f6f

Today I installed update to Windows portable version of Joplin. Joplin 2.11.11 (prod, win32)
I added new folder and 2 new notes to that folder
I edited one existing note
I sync to Joplin server. No errors reported
I sync to 2 mobile devices, one IOS and other Android, both running latest versions

Both mobile devices are unable to decrypt the newly added folder and messages and the newly edited message.

This broke with the new update to windows portable. Up to this point all syncing was working perfectly. Something in the new version broke encryption/decryption sync on the mobile devices

Very important, how to resolve the decryption issue on the mobile devices without losing important data.

Just tested again adding new note with title test and text test. Very small note and synced. Again, the mobile app can't decrypt it. This is serious issue!

Note, adding a new note on mobile and syncing to server, then syncing in windows app works fine. The issue is when adding/editing note on Win portable and syncing to mobile. Mobile apps can't decrypt any changes since the update to Joplin 2.11.11 (prod, win32)

Also, how can I download the previous portable windows version so I can roll back?

Thank you.


The most recent release of the iOS app was about 7 hours ago! Please double check that the Joplin iOS version is 12.11.5.

My version is 12.11.3. I'm not seeing any update available.

Note, I did see an update for android app. I updated, however Joplin gave up on trying to decrypt the items so I deleted cache and data, synced all again from server. This fixed the issue on android. All items decrypted fine.

What version of iOS are you using? (It's possible Joplin hasn't updated for older versions of iOS.)

Its a new ipad pro I got this year running IOS v16.5.1

Try searching for "Joplin" in the App Store. Does it say "open" or "update"?

If it says "open" and the latest version is listed as 12.11.3, it's possible that the app takes longer to review in some regions (this is just a guess). If this is the case, it may take several more days or hours for the app to be reviewed.

To answer the original question about how to roll back, I suggest looking at the releases page on Joplin's GitHub.

It says "Open". No update currently available in west coast of USA.

Thanks for the info on releases. I don't think it will be necessary to rollback as the updated android app fixed the issue on that device. I surmise updating the IOS app will fix the issue on that device as well. I will wait for the IOS update and sync with the updated app.

Joplin stops trying to decrypt the items so I may have to sync all again to force it. Is there a setting in the IOS app to remove all local data and sync again from the server? I see that setting in the windows app, but not in the IOS. Is it just not available on the mobile apps and the only way is to delete the app and data and download, sync all again?

I'm also on the west coast, but I'm on an iPhone. It could be that the iPad and iPhone apps take different times to review (again, this is just a guess!).

Regardless, this is certainly very annoying! (In the future, we should try to make sure that new versions are available for all devices before publishing a release that breaks compatibility).

Is it just not available on the mobile apps and the only way is to delete the app and data and download, sync all again?

It isn't available on mobile apps, however, a workaround might be to create and sync a second profile (then delete the original profile).

Also, noticed just now this in the release notes: Improved: Upgrade E2EE encryption method to AES-256

This explains why the mobile apps requires an updated version to decrypt

1 Like

update for IOS just showed up. Deleted and installed update. Synced all and perfect. No decrypt errors. All good. You can close this as resolved.

Thanks again for your quick response. Love Joplin!


I just encountered this issue trying to sync notes on my Linux system. I run Joplin on Windows, Linux and Android. After I installed 2.11.11 on Windows and updated a note, I started getting "Encrypted" on that note on Android. So I fired up the Linux system, same result there - "Encrypted". So, I downloaded the latest AppImage version from the Joplin site for Linux, which claims to be 2.11.11. However, when I started it up and check Help->About, it says 2.9.17. I repeated several times just to make sure I hadn't done something incorrectly, but got the same results each time.

Looks like the LInux version at least has been incorrectly built. I noticed in the release notes that there was an update to encryption: "Improved: Upgrade E2EE encryption method to AES-256 (#7686)". Perhaps this is what is causing the issue. When I disable encryption, everything syncs fine between Windows and Linux.

Try downloading from the GitHub releases page: Releases · laurent22/joplin · GitHub

Edit: I'm getting this from the downloaded AppImage:

(To ensure an existing installation wasn't being used instead, I created and tested with a new user account).

Was Joplin originally installed with the install and update script? If so, try updating it with the same script.

Additionally, please double-check that the AppImage is being launched correctly (e.g. do so from the command line, if you aren't already).

User error, I suppose. After reading the last two replies, I tried a couple more times, same result. Then I did "ps -ef | grep -i joplin", I saw there were a couple detached versions of Joplin running. So, apparently, when I ran from the command line, Joplin switched to an already-running instance, which of course was the old one. I don't know how those detached instances came into being - perhaps from all the failed syncs.

I killed all those running instances and ran again, and this time it reported 2.11.11. With the new version, I am no longer getting the Encrypted issue on my Linux system. So I'm surmising this was an incompatibility of the "Improved: Upgrade E2EE encryption method to AES-256 (#7686)".

1 Like

Excellent! I'm glad it's fixed. (Ideally, the ability to decrypt AES-256 encrypted notes would have been added several versions before the switch from AES-128 to AES-256.)

I ran into something similar today. On a Mac I rarely use I was prompted to upgrade and did so without thinking too much about it, back on my usual Ubuntu desktop I started seeing sync errors. I had to switch from my flatpak version to the appimage as the desktop did not suggest an update. But once I was running 2.11 instead of 2.10, I was able to see my latest changes again.

1 Like

I updated today to version 2.11.11. I have directories containing profiles on my Synology NAS. My typical workflow is to create a new profile, on sync settings I'd webdav into the NAS and point to the directory containing a profiles.

The Joplin sync spins, says completed 2023.06.27 4:23PM (6s) and ITS BLANK. Using the same profile I try a different directory. ITS BLANK.

The directory is a copy of a working profile. I simply moved the data to my second NAS. I am trying to view the contents to get some things out of it. Is this version broken?