Ubuntu 18.04.1 Gnome top menu black icon


I used the script to install before and everything worked fine. But today on a fresh Ubuntu install, the menu shortcut was not created. Same issue and fix as this.

But the icon in the top menu is still not right. This was fine too on my last install and I’m not sure what’s changed. I see a solution here-

Should be fixed with recently added install_ubuntu.sh script.

But I don’t know what that means or if I can fix something. Anybody else having this problem?

This is odd, it should show this icon only if the platform is Darwin. Gnome doesn’t happen to identify itself as Darwin, does it?

If you have node installed, any chance you could run this script to verify?

For example create test.js with this content:


Then run node test.js

I’ll see what I can do but that sounds above my skill level. I’m new to all of this.

I had this same issue on my last Ubuntu 18.04 install when I downloaded the appimage myself. But using the recommended install script instead fixed it.

Ok that was easier than I thought.

The output is just