Turn off fading text in todos

Hello Joplin forum,

I am a new Joplin user and have a question about the todo list feature. Specifically, when I use a todo list it tends to have nested items in it (i.e., tasks, with underlying subtasks, and underlying sub-subtasks, etc.). When using the WYSIWYG editor, I notice the text for the lower-order tasks fade when they are marked as complete. The amount of fading appears to increase the further you go into subtask levels such that any completed sub-subtasks are almost unreadable and anything below that is completely invisible for me. It can be helpful for me to see what tasks I have already completed without switching to the Markdown editor.

Is there a way to disable this text fading in nested todos for the WYSIWYG editor? I tried to find the solution on my own through the app itself and this forum with no luck. Any help would be greatly appreciated.

Thank you.

Joplin: 2.11.11 (prod, darwin)
OS: macOS Catalina 10.15.7

@wtb295 welcome to the forum.

I do not use the Rich-Text editor but I had a look and it seems that if you put the below css into userstyle.css the checked checkboxes will no longer fade.

li.checked {
    opacity: 1 !important;
    /* sets the opacity of the checked checkbox text*/

"Before" and "After" screengrabs

If you have not tried custom css yet, this wiki page should give you an introduction.


Screen Shot 2023-07-30 at 10.12.23 AM


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.