Homepage    |    Wiki    |    GitHub    |    Twitter

Terminal app with iTerm2: Extra lines after startup

My iTerm2 terminal keeps dumping extra lines on startup of the Joplin terminal app on MacOS (no problems with the built-in Terminal app). I suspect this can be resolved with an iTerm2 setting, but I was unable to determine the proper configuration to resolve this issue. Any suggestions? See image for comparison between the startup of joplin-cli with iTerm2 and Terminal (extra lines are on the bottom of the iTerm2 terminal).

Versions:
joplin-cli: 2.6.1
iTerm2: 3.4.14
Terminal: 2.12 (443)
MacOS: 12.1

Resolved by setting "Terminal type" to "xterm-256color". Found in iTerm Preferences -> Profiles -> Currently used profile -> Terminal -> Report terminal type -> xterm-256color.

My issue was caused by using the terminal type "ansi". Now Joplin starts up in the terminal with proper formatting and no extra lines.

2 Likes