Having trouble installing the terminal version of Joplin

I am having trouble installing the terminal version of Joplin on my MacBook Pro 2021 Apple M1 Pro, running Ventura 13.1. I tried following the instruction on the Joplin site, but I got 15 notices of "deprecated" attempted installations, followed by over 40 "ERR!" messages. (I have the error log, if anyone wants to see it.) Then I found some alternative instructions someone posted in an old message on here. I tried following those instructions but go the same result. I tried installing it with homebrew, which put Joplin into a cask -- I'm not sure what that means, but I don't seem to be able to access it. Has anybody got any ideas? Insights? Suggestions? I mean the desktop and iOS version of Joplin are working very well for me. I don't have to access it via the Terminal, but it would be fun to be able to do so.

1 Like

Error log should be provided as a minimum, yes. Can't really tell what is going on otherwise.

2023-01-03T15_54_04_970Z-debug-0.log (314.6 KB)

That error log is the output after I ran this command: NPM_CONFIG_PREFIX=~/.joplin-bin npm install -g joplin. I then tried to run the second command: sudo ln -s ~/.joplin-bin/bin/joplin /usr/bin/joplin. To which I got this response: ln: /usr/bin/joplin: Operation not permitted

Looks like you need to install libvps Doc: Add libvips dependency for Apple Silicon build instructions by nickhobbs94 · Pull Request #5966 · laurent22/joplin · GitHub

That didi it. I've finally got the terminal version of Joplin running. Now, I've been searching everywhere, but I'm not sure how to set up the terminal version to synchronize, either locally (with my desktop GUI version) or with JoplinCloud. I'm supposed to specify the folder in which my desktop notes are stored, but I haven't been able to dope out just where that is. Is that the only way to synch between terminal and desktop -- or is it possible to synch the terminal version with JoplinCloud?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.