Home / GitHub Page

Table: width of the cells

#1

Hello!

I try to use tables in Joplin (Windows client) but I have problem width the width of the cells. I try to control the width with the amount of — but it doesn’t work. Sometimes the width of the cell is just fixed and the text breaks into another line. And this even when I try to enlarge it in the caption line.
Here a table like I built them:

Code: | | | |
| ---------- | — | — |
| Test 1 | Test 1 | Test1 |
| Test 2
| Test 3
|

Do I miss something?
Thanks
Martin

0 Likes

#2

What you posted is not a valid table, for example the “—” are replaced by a “—”, so please post again the actual markup you are using.

Also see there for info on how to make tables: https://github.com/adam-p/markdown-here/wiki/Markdown-Cheatsheet#tables

0 Likes

#3

Hmm, it looks like the same happend to you. So I just made 4 “-” and not 3 “-” in a row.

Code:

| | | |
| ----------------------- | ---- | ---- |
| Test 1 | Test 1 | Test1 |
| Test 2
| Test 3
|

Wenn I copy that code into joplin I get a table but the width of the cells is not defined correctly

0 Likes

#4

Indeed it seems Discourse is replacing the characters. Could you put your code inside a code block? To do that, select the text and, on the toolbar, click on “Preformatted text”.

Edit: I’ve just done it for you. The syntax seems to be fine - what’s not working for you? i.e. what’s your expected result?

0 Likes

#5

I would expect that the first column has the width I defined with --------------------- but it has the same width like the others.

0 Likes

#6

Do you mean that the columns should be merged into one? Maybe some info there https://stackoverflow.com/questions/23571724/github-markdown-colspan

0 Likes

#7

From my understanding pure markdown doesn’t support what you want. But you can enable this behavior in config but toggling on the MultiMarkdownTable plugin.
Here is the website for reference on that plugin.

0 Likes

#8

I took a look at multimarkdown and the post on stack overflow. But what I want is still simpler. I try to explain it better. This is what I expect to see:

Code:

| | | |
| -------------------------------- | ---- | ---- |
|            column 1               | column 2 | column 3|
|            column 1               | column 2 | column 3|
|            column 1               | column 2 | column 3|
|

The column 1 has exactly the width I defined in line 2 with the -
But what I get is this:

column 1 column 2 column 3
column 1 column 2 column 3
column 1 column 2 column 3

Every column has the same width.
I have some notes imported into joplin from evernote where the columns have different sizes but not correlated to the text. And I am not able to change the width of the columns of those tables.

Thanks for your patience.

0 Likes