Home    |    GitHub Page    |    API    |    FAQ

Synchonization failure

Hi there,

The synchronization in my desktop version has recently stopped working. The button indicates that the synchronization is in progress but will not stop. Tried to use a different sync target but that doesn't change anything.

Joplin 1.5.14 (prod, win32)
Windows 10 Home, Version 20H2

Many thanks for the help

If you can also please provide a log, as described here: https://joplinapp.org/debugging

Hello JackGruber

I don't know if I did it right. I'll add a file: "Joplin - console - output of warnings.txt". The file "log.txt" in "\ .config \ joplin-desktop" only contains entries from 2019-08-25. Is that important too?

best regardsJoplin - console - output of warnings.txt (104.4 KB)

The c:\Users\fktho\.config\joplindev-desktop\log.txt should actually contain new entries.

But I have seen one error, this is an error from the WebDAV server.

Error: DELETE locks/sync_desktop_6737dad061c9483baa4191dc37069578.json: Unknown error 2 (409): <!doctype html><html lang="en"><head><title>HTTP Status 409 – Conflict</title><style type="text/css">H1 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:22px;} H2 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:16px;} H3 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:14px;} BODY {font-family:Tahoma,Arial,sans-serif;color:black;background-color:white;} B {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;} P {font-family:Tahoma,Arial,sans-serif;background:white;color:black;font-size:12px;}A {color : black;}A.name {color : black;}HR {color : #525D76;}</style></head><body><h1>HTTP Status 409 – Conflict</h1><hr class="line" /><p><b>Type</b> Status Report</p><p><b>Description</b> The request could not be completed due to a conflict with the current state of the target resource.</p><hr class="line" /><h3>Apache Tomcat/7.0</h3></body></html>

But an other problem is your sync target is empty?

Fail-safe: Sync was interrupted because 99% of the data (225 items) is about to be deleted. To override this behaviour disable the fail-safe in the sync settings.

Hi JackGruber,

many thanks for the help. That's right, the log.txt file also contained new entries. My mistake. In the end I just reinstalled everything and now it works. (Regarding the hint of the empty target: I had tried another target to understand what was happening. The problem was also present with the actual target.)

Thank you very much and good luck!