Home / GitHub Page

OneDrive Sync Error

I recently set up a new instance of Joplin, and I am getting a OneDrive synchronization error for some reason on my desktop (Windows 10 Home / 64 bit). I have less than 10 notes in there, but nothing too crazy as far as formatting goes within notes as far as I can tell.

This is the text of the error I can see in my Joplin window:

Created remote items: 1.
Completed: 08/01/2020 6:23 PM
Last error: SyntaxError: OneDriveApi::exec: Cannot parse JSON error:

  • *
  • *
  • Runtime Error*
  • *
  • *
  • body {font-family:“Verdana”;font-weight:normal;font-size: .7em;color:black;} *
  • p {font-family:“Verdana”;font-weight:normal;color:black;margin-top: -5px}*
  • b {font-family:“Verdana”;font-weight:bold;color:black;margin-top: -5px}*
  • H1 { font-family:"Verdana*

Syncs seem to work fine on my Win 10 / 64 bit laptops that are connecting to the same OneDrive account and Joplin sync instance as well as my Android/mobile app.

This is what I am using on my desktop.

joplin_version

Any ideas? Or any other info I can provide to help troubleshoot?

It looks an uninstall and reinstall and resync resolved the issue, but as soon as I copied and pasted some simple HTML from a web page and into a note, I got the same error again. Working on recreating again.

I had similar errors after I made a lot of experiments with the API. To get rid or them I stopped Joplin, deleted the joplin-desktop folder in %userprofile%\.config, restarted and reconfigured the synchronization (already mentioned yesterday in another thread). Notice that you will lose the notes that are not yet on OneDrive.

Thanks, after a full Joplin reinstall I was clear for a little bit on my desktop machine. Then the same error happend again, I deleted the joplin-dekstop directory, tried to reopen, and now I cannot seem to re-synchronize with OneDrive. When I click the link to authenticate, I get redirected to log into my MS account, but then I am immediately redirected to an error page.

http://localhost:8967/?error=server_error&error_description=The%20request%20could%20not%20be%20completed.%20Please%20try%20again%20later.

Did you try again later? In the logs of our backup systems I see that some Office 365 services were not available around midnight UTC.