Synch error

Operating system


Joplin version


Sync target

Joplin Cloud

What issue do you have?

“TypeError: Cannot read property 'filter' of null.” Further info: “Fetched items 5/69.”
Tried synch both from iPhone and iPad Mini. Got same error. Changes had been made to Desktop (Mac) version earlier today.

Information from the log (Tools > Log > Errors only) may be helpful here — this might help determine where specifically this error is coming from.

Thank you for reporting this!

mobile-log.log (771.9 KB)

mobile-log.log (55.3 KB)

The second one is the Errors Only log.

I tried doing a "Re-upload local data to sync target" from my desktop Joplin (on Mac), but even after that, I'm getting the same error from my iPad Mini and my iPhone. The only difference is that on my iPad Mini it says, "Fetched items: 5/69", whereas on my iPhone it says, "Fetched items: 1/55." Same TypeError on both: "Cannot read property 'filter' on null."


Is the Joplin version 12.14.1 on both the iPad Mini and iPhone? (The latest version should be 12.13.10. The version can be found under "More information" in settings).

Yes, the version on both the iPad Mini and the iPhone is shown as 12.14.1. On my laptop, the desktop Mac version is shown as 2.13.12 (prod, darwin). Should I downgrade the versions on the iOS devices?

"export JEX > Create new profile > Switch to new profile > Import JEX > synchronize with clean new folder"

In my experience, this action resolved most of the errors.

@CandaceSoVan, I think this issue has been fixed, but it hasn't been released yet. In the meantime would you mind uninstalling this 12.14.1 version and reinstalling the 12.13.10 version (from the store)? If you're still getting an error after this please let us know.

Edit: If you have notes that are only on iOS and haven't synced to desktop, make sure you save them first. If there's just a few simply copying and pasting the text elsewhere might be enough.

I had the same error with Android 2.14.2 and 2.14.1 (tried to downgrade).
Downgrade to 2.13.10 was not possible, so I uninstalled Joplin 2.14.1 and installed 2.13.10 (full sync from server).

Version 2.13.10 doesn't have the sync error.

Moreover, the Joplin author has deleted distributives for both 2.14.* versions on GitHub. I guess he has found the error, but can't fix it quick.

I uninstalled 12.14.1 from both my iPhone and my iPad Mini, reinstalled the 12.13.10 versions, and then synched everything to both devices. It took a few hours, but now everything's working fine on those two devices. I seem to be having some synch issues on my iPad Pro Gen 3, but that device is running version 12.13.10. I'll see if time will straighten that out. If not, it's a different issue. Thanks, as always, for your responsiveness and good suggestions. It's hard for me to function when my Joplin installations aren't all humming along! :smile:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.