Sync path on Android

I setup Syncthing successfully between my Win10 PC and my Samsung S21 Ultra phone, with Android 11. All of the data from the PC has synced to the phone.

The relative path under Syncthing is "Joplin". The absolute path in the Android file browser is "/internal storage/Android/media/com.github.catfriend1.syncthingandroid/Joplin".

When I input the absolute path into the Android Joplin app, it appears to take it (no messages). When I click Syncronize, nothing happens. I tried adding a "/" at the end of the path, but still, nothing happens.

Any ideas?

This is a very strange path. Can you check with a file manager (X-plore for instance, but any other should do) that this path is indeed correct?
For the internal storage I'd expect something like /mnt/sdcard/...

Yes, I know that the path looks a bit different. I assume that the difference is due to either Android 11, the fact that the S21 Ultra has no SD card, or both.

That is the path shown by the Samsung "My Files" file manager. I'll install another one and have a look.

Cx File Explorer shows the path as "/Android/media/com.github.catfriend1.syncthingandroid/Joplin", without the leading "/internal storage".

Still no sync, however.

FX File Explorer shows the path as "/storage/emulated/0/Android/media/com.github.catfriend1.syncthingandroid/Joplin".

Now Joplin is syncing.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.