Sync problem on android

Joplin 1.0.312
Android 7.0
I tried to setup sync to a local directory on my Android phone. The directory is on an external SD card. When I save the updated configuration I got the prompt whether to give Joplin access to storage and I selected “yes”.
However when syncing I get the error “Error: Directory could not be created, Path: /storage/CEE4-AE44/MegaSync/Joplin/.sync Code: EUNSPECIFIED”
When I check app permissions in android settings I see permission for “storage”

I am not sure whether this is an authorization problem or a problem with the path specified incorrectly … so first step might be “can this be concluded from the error message”?
– but I am lost how to resolve either of both problems: I do neither know what might be wrong with the path nor what could be done to give Joplin additional permissions …

1 Like

You have already given the proper permissions, so there are 2 options:

  • the directory /storage/CEE4-AE44/MegaSync/Joplin/ does not exist
  • another app locked the resource for writing
1 Like

Hi, hello to everyone here. :wave:
On PC (Windows 10 64-bit)
Joplin 1.5.14 (prod, win32) JoplinPortable.exe
On Android: Android 10, SG Note 10 Lite
Joplin 1.5.1
After many attempts Joplin synchronization (File system) between PC and Android was successful.

I took advantage of the fact that Joplin by default has access to write in two similar folders: the first one in internal memory, the second one in external memory, and the path to access these folders is '.../Android/data/net.cozic.joplin/files/...' :point_left:.
I used only second folder to synchronize Joplin (this on external memory = MicroSD card).
Its path looks like this:
The name 'C####-####' corresponds to the 'CEE4-AE44' quoted in the post and the nested user folder has any name, for example I used 'MyJoplinSyncFolder'.

To synchronize the external synchronization between the PC and the Anrdroid device I used a WDMYCLOUD network drive (available on the network as SMB1) . The folder on this disk was accessible to the PC and Joplin application in a simple way, with user account login and password for WDMYCLOUD resources.

From the Android side (SG Note 10 Lite) I had to support synchronization with a separate application 'FolderSync Pro' (of course you can use another one).

This synchronization chain works in two ways. I will continue testing it. I would like to use the possibility to assign a direct access path to the WDMYCLOUD disk for Aandroid-Joplin synchronization. I tried many times, but Android-Joplin does not accept my proposed paths. :disappointed:
Maybe somebody will find a solution how to allow Joplin application on Android to access home network drives...
Regards, JurGraf. :slightly_smiling_face:

You can start this as new topic instead of posting as a reply, so that someone will help you. Thanks

1 Like