Sync error/Antergos linux


I really like the application and has been working great on my android phone. I run Antergo Linux which is Arch based. I was able to install Joplin from AUR (Joplin 1.0.85 (prod, linux))
I get an error Unknownfiels:parent_id. I only see 2 notebooks, but there should be more.Screenshot%20from%202018-05-15%2016-58-31

Is it possible that the error is due to the fact that some notes were created on a windows 7 PC?
Any suggestions for troubleshooting is appreciated. Thank you.


Hello, you need to install the latest Linux version to fix this issue.

Antergos is a rolling release like Arch. To my knowledge there is no version # like one has for most other distros. Is there a particluar package/dependency that is causing the error? My OS is updated as of today.

I think he meant the latest version of Joplin. That error is what you'd get if you synced your notes from a .91, say on Windows, and then tried opening them on .85 on Linux.

I had the same issue here:

That was w/ the Portable app. Fixed it by updating, when update became available.

@zblesk so I am currently having the same issue, as I was using the latest android version and also the latest availalbe arch linux version from aur (1.0.85)

I thought it might have to do with the versioning. So I did a pull request and now the latest version is available in the aur (1.0.93), however I still have the issue that my old notes which work fine on android cannot be imported into the desktop app, with the “Error: Unknown field: parent_id” error. Any suggestions on how to migrate the files (which btw all contain the corrent parent_id field as far as I can see)?

Do I have to wait for a newer android app now (latest version from github, doesn’t seem to have made it to the app store yet)?

@laurent are file incompatibilies between minor versions to be expected or is this just a bug? Otherwise that seems like a braking change for me

@texhnolyze, it sounds like the desktop app is still not the latest version - could you check the version number in Help > About?

It is version “1.0.93 (prod,linux)”, the notes were however created originally with 1.0.85 then imported to the latest android app (1.0.124), which worked nicely and then edited on my phone.
Upon a resync back to the desktop app the error occured, which is why I then upgraded to 1.0.93.

The error I get in the log is the following:

Error: Missing required property: type_: id: c594ee549be34213aa859b758d6d468d
updated_time: 2018-05-16T02:48:32.224Z
encryption_cipher_text: JED0100002201243267abf0ad4dc982f2739d8c4ae14f000212{"iv":"+gWHGD1Zhkb8qI5ebUS9yQ==","v":1,"iter":1000,"ks":128,"ts":64,"mode":"ocb2","adata":"","cipher":"aes","salt":"ZxNq/lDnla0=","ct":"AdnYJrhZ/2HXVF5VJXW6GDL0mYKBhIKsykvas7sVg6uBoYY5yGBWVi1UBpfO2hH4uZIZHx7M68CjA31A5l72MgHTIOxoU7yyInR8zJ8QlCu2OSlkf7+QqoD5engPTnQ1Aw16nWUyngbMJ2TCxXyekFdn1FYJB3FvHgWgshbdQlGn9VUQirYRp99Oth8+T6V3Bm/r8Dz4zGUpb/EbRNe4wbnwMcAK5ZM3A2sOhCKnv+xGvi3gYyyxLeYb3/swn2uc5Q/L81FB/O3VGbaZ17QuUD6KED/rcB1KwQ6UZLpmv9X37qEJ2j7ASecSYvZwupowEWYhLFo3ZyIgRpnsMW9i0btC0mlri8xd4ymryz9ZU7x7EXhwb/k3aO+xxvSI6qj1Vo/2E7E="}
encryption_applied: 1
type_: 2

    at Function.unserialize (/usr/share/joplin/resources/app/lib/models/BaseItem.js:342:28)
    at loadContent (/usr/share/joplin/resources/app/lib/synchronizer.js:479:30)
    at <anonymous>"

which doesn’t really make sense to me, as there is clearly a type value shown in the log.

I’m currently checking out the master branch to see what’s actually getting unserialized. How would I go about getting some debug output? Is there a log written when testing, because console.log is not giving me any output in the development tools.

@laurent nevermind I found the issue:

I must have touched one of the files with an editor or something, which added a newline a the end of the file and because the BaseItem unserialize method steps through the lines in reverse and thinks it has hit the end once it hits an empty string line it never assembles a model from the file and says the model is missing a type_ key, because it is indeed an empty object.

So sorry about that, this would be my own fault :blush:. Will do a pull request tomorrow for a sturdier implementation.

Thanks for the awesome project btw :+1:

1 Like

@jimmyg So the best option for you would be to update to the latest aur version, which was bumped (since your using Antegros I assume you installed from the aur). If that doesn’t fix it look remove newlines at the end of the files containing the folders/notes (make sure your editor doesn’t automatically add those).

@texhnolyze and others: The issue is resolved once the update showed up in AUR. All good now. Thank you for the wonderful application!


can you tick the “solved” checkbox, so we all know a solution exist ?