Sudden small editor fonts

Hi

Suddenly my editor fonts are tiny. I am not sure if it started with 117, I was not paying attention then. See the image.

I did not change any settings , it was fine up until couple days ago.

My global zoom factor is already set up to 160 and editor font is 13



A new setting was introduced to set the editor font size. You will find it in the Config screen and can increase it there.

In theory it should have used what was default before though, so it’s strange it did this. Perhaps @CalebJohn would know about it?

Ok that explains the sudden change, I will take a look at the new setting.

I am on Linux btw

Hi!

Yes this problem is from editor font change, basically anyone that has a zoom of anything besides 100 will experience this problem because font size of the editor is no longer tied to the zoom level.
We can potentially scale the font with zoom as well as the editor font setting. It’s up to you.

I too have this problem, even though I have set my zoom level back to 100 (it was previously at 130). Where is this config screen where the other mentioned font setting lives? I only can find the setting in Tools > General Options (on Mac).

It should be on the same screen directly below style.zoom.
Can you send a screenshot of what your seeing (not seeing)?

Are you talking about the font size option? I’ve tried changing that number, but it doesn’t seem to actually affect the font size, which is still extremely tiny:
10%20AM

Yes that’s the correct one! Sorry for being unclear
Unfortunately because of the way theming is currently handled, you’ll need to restart joplin after changing the font size (or the global zoom percentage).