Starting joplin appimage minimised i3 window manager?

Hi, in my Joplin Desktop on my EndeavourOS i3 I have the start minimized box ticked, but it doesnt start minimised.

Its started at startup in my i3 config file by:

exec --no-startup-id /opt/appimages/Joplin.AppImage

Anyone know how I can start it minimized?


Joplin 2.7.15 (prod, linux)

Client ID: 126e3111514342699f98e75580602803
Sync Version: 3
Profile Version: 41
Keychain Supported: No

Revision: 8352e23

I believe minimising is disabled on linux entirely so the option won't do anything regardless of what you set. Something to do with the tray on GNOME not playing nicely I think?

Thanks @Daeraxa

So, I pondered a bit and thought that maybe I could get the behaviour I wanted by just killing the Joplin window straight after auto-starting it in my config, and after some searching I cobbled together this, which worked! :smiley:

#Autostart Joplin.Appimage 
exec --no-startup-id /opt/appimages/Joplin.AppImage
# Then shut Joplin window, leaving it running in Tray
exec --no-startup-id i3-msg '[class="Joplin"] kill'

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.