No Launch on Fedora 38

Hi All,

Just wondering if anyone has upgraded to the recent release of Fedora 38 and tried launching Joplin? After upgrade Joplin appears to no longer be able to be brought to the foreground. The background processes appear to be running but the app cannot be brought up.

Thanks for any input.

I am not a Fedora user but out of interest I installed Fedora 38 into a VM and installed Joplin using the official bash script. After install Joplin appeared when started.

1 Like

Thanks for the reply! Sounds like I may need to just reinstall and import from backup.

I'm occasionally experiencing a similar issue on Ubuntu 23.04 (installed using the unofficial snap method):

Closing Joplin and re-opening it fixes the issue.

From what I can see Gnome 44 does not appear to support minimised applications. There should be a list of background applications in the top right quick-settings menu but apparently (1) this only works for Flatpak applications and (2) if the application is a Flatpak it only lets you shut down the application, not restore it. So from what I can see, in Gnome 44 there is no simple way to restore a minimised application or even to easily tell if one is running minimised. I am not a Gnome user, I may be missing something.

It may be worth checking that "Start Minimised" is not set in Joplin settings. It looks like a minimised Joplin can be displayed by going to the list of applications and running it again. If this fails editing "startMinimized": true, to false in ~/.config/joplin-desktop/settings.json may be an option.


Did you install with one of my RPMs? If so, I was late in building the RPM. Try again?

Thank you so much! This looks to be the issue. It's truly baffling that the Gnome team removed this functionality in v44. This has broken my ability to open my Mullvad client as well. I will have to switch to KDE until this is fixed.

Additional reading:

The menu now lists apps which have been detected to be running without an open window. This feature makes it possible to check if a particular app is running in the background. Currently only Flatpak apps are included in the background apps list.

Source: GNOME Release Notes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.